I bought a new desktop PC (eMachine ET1331G-03W from WalMart) with windows 7 installed, but I can not access internet by connecting to my existing wireless router(LinkSys BEFW11S4) with wired cable. Though all other existing desktops and laptops have no problem connecting to the same router. However, the new desktop PC works fine and able to connect to internet if I bypass the router and directly hook up with the cable modem.

At new PC when connecting to the router, I got the below information by typing ipconfig, the IP address looks wrong to me:

autoconfiguration IPv4 Address: subnet mask: default gateway: (empty) NetBIOS over Tcpip: Enabled

Typing ipconfig at all other desktop and laptop have values like below, which are good to me:

    Connection-specific DNS Suffix  . :
    IP Address. . . . . . . . . . . . :
    Subnet Mask . . . . . . . . . . . :
    Default Gateway . . . . . . . . . :

The wireless router was on, I do not know why the new desktop got IP? It should have something like 192.168.1.xxx, and it was configured to automatically get IP by DHCP.

I have tried to switch cables,power off cable modem, router and reboot new pc many times and got no luck. So I believe this is only an issue related to router or new pc configuration.

Can someone help me figure out the issue?

migrated from serverfault.com Feb 14 '10 at 18:39

This question came from our site for system and network administrators.

  • Does it work if you set a static IP (running it off the router, not the modem)? Also, have you tried a known-working port on the router? – user5195 Feb 14 '10 at 15:17
  • the 4 ports at my router are all good as I have switched between to test. How can I try a static IP at the router as you suggested? – Anonymous Feb 14 '10 at 15:37
  • is this question more appropriate for SuperUser.com ? – p.campbell Feb 14 '10 at 17:57

The IP address that your computer got is called an APIPA address. Most likely your new computer does not have DHCP enabled or your router has run out of DHCP addresses. If you need help checking those values let me know.

  • Thanks, Greg, can you help me check this? – Anonymous Feb 14 '10 at 15:29
  • point your browser to the address of your router..which is It should ask for a userid and password. Once logged into your router...follow the instructions found here: setuplinksys.com/How-access-Linksys-Routers-Setup-Page-3298818 – GregD Feb 14 '10 at 15:49
  • particularly check to see what your "Number of Addresses" box says. It should be 50 by default. – GregD Feb 14 '10 at 15:50

Does your router give IP-addresses based on MAC-address? The new PC's MAC is not registered in the router therefore it does not get a real IP.


What is the full output from ipconfig /all ?

What is the output from

ipconfig /release
ipconfig /renew

If you look at the connection status, are packets being sent and received, or just sent?

Clicking 'repair' in that gui thing does mostly the same thing as running ipconfig /renew, but catching the output is trickier..


Here is what I would try to do to remedy this problem before calling it a hardware issue and buying a new network card.

  1. Try multiple CAT5 cables and different ports (you have done this)
  2. Try ipconfig /release, ipconfig /renew at the command line (this is same is repairing)
  3. Set a static IP
  4. Reinstall the network card drivers (by uninstalling the card and restarting the comp to force the card to be reinstalled - very simple and safe)

ARe you using XP, Vista, Seven? I will post instructions for setting static IP

EDIT ok after re-reading the question I see that you are using Seven..standby for more...

EDIT - instructions are easily on Google for setting a static in SEven. Just be sure to set settings that are relevant to your routers configurations. This can be done by looking at ipconfig /all on one of your other machines.

Here are some freshly Googled instructions.

last edit - if all of this fails, uninstall the network card. This is totally safe and will be reinstalled at restart. The card can be uninstalled by expanding the view in device manager, right clicking on the card, and selecting uninstall. Once this is done, restart the machine.


thanks every one for the answer. I tried the static IP, still does not work. I suspect the router may not support windows 7 64bit. The other PCs connecting to the router are all Win XP. I will get a Win 7 certified router, and try again.

  • Confirmed, the issue was due to the old router (LinkSys BEFW11S4). I bought a new router, then all worked. – user28286 Feb 16 '10 at 14:18
  • User: that is sort of disappointing to hear, because it suggests that the built in DHCP server is not compatible with Windows 7, for some reason... I have a friend who has a similar kind of problem, the web interface on his BEFW11S4 seems to be so old, the form submit on the admin pages doesn't work. – benc Mar 24 '10 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy