1

The Issue

Recently, my computer has taken to connecting to weak APs on the network. Starting earlier this week, I noticed a significant drop in network quality (From 40 Mbps to 4 Mbps tested using speed test sites).

My investigation revealed that the computer is connecting to what appears to be weak BSSIDs within the SSID group. I suspect that these BSSIDs belong to routers on the floors above and below me. Running wlan show interface in netsh reveals that Windows detects these weak BSSIDs have a quality of 99%. Because of this high quality, Windows priorities these BSSIDs. However, the quality of the signal immediately drops to ~60% as soon as there is traffic on the connection.

Due to these circumstances, I have several questions:

  1. Why does Windows give the weak BSSIDs a high quality?
  2. What could have changed to cause this issue (as it was working fine before)?
  3. What are possible solutions to ensure I connect to the actual "best" BSSID (ideally fixing the fact that Windows rates the weak APs highly)?

Other Details

  • The computer uses Intel's Dual Band Wireless-AC 7265 adapter (Which has up to date drivers)
  • No updates/new software packages were installed when this issue began.
  • I assume my other devices (Phone and Tablet) pick the right BSSID every time, since they show ~40Mbps.
  • I have tried using Intel's connection tools to pin the BSSID to one which I know performs well, however it does not seem to work.
  • I have tried increasing the roaming aggressiveness of the wireless driver, but this yielded similar results.

Related Questions

Connect to Wi-Fi access point with specific MAC address

How can I connect to an Access Point by BSSID instead of ESSID in Windows 7?

1

I was in your same situation.

My PC (win10) seemed to prefer the BSSID most recently detected by the WiFi-interface, even though I was already connected to an excellent BSSID, with good signal.

To solve all that, I decided to use a third-party software for the manual selection of the BSSID (i.e. NetSetMan, but you can find many others on the Web) and then {important} I lowered (actually disabled) the aggressiveness of roaming.

How to do:

Identify your WiFi-adapter or wireless device. Double-click on the entry to open its Properties box.

Now under the Advanced tab, scroll down the Property list till you see Roaming Aggressiveness or Roaming Sensitivity.

Open the Win10 menu by right-clicking on Start and selecting Device Manager. Expand network adapters and identify your wireless device. Double-click on it for to open Properties: choose "lowest" as value in drop-down menu.

  • Lowest: Your device will not roam.
  • Medium-Low: Roaming is allowed.
  • Medium: It is a balanced setting between roaming and performance.
  • Medium-High: Roaming is more frequent.
  • Highest: The device continuously tracks the WiFi quality. If any degradation occurs, it tries to find and roam to a better access point.

I hope this will help. Bye!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.