0

My internet connection is provided by my university

Case 1

My University -> Laptop direct connection

Everything works fine here

Case 2

My University -> Netgear WNR614 with DHCP -> Laptop

IPv4 works fine, curl -4 url requests are perfect, but curl url times out / takes too long to load

Case 3 My University -> Netgear (with DHCP server off) -> Laptop

Everything works fine as usual.

What might be the issue here? (The DNS servers provided by my university are local addresses)

Here is the diagnostic result with DHCP by router

Test with IPv4 DNS record       ok (0.766s) using ipv4
Test with IPv6 DNS record       timeout (16.490s)
Test with Dual Stack DNS record ok (0.854s) using ipv4
Test for Dual Stack DNS and large packet        ok (0.803s) using ipv4
Test IPv4 without DNS       ok (0.816s) using ipv4
Test IPv6 without DNS       bad (0.009s)
Test IPv6 large packet      timeout (16.439s)
Test if your ISP's DNS server uses IPv6     timeout (16.430s)
Find IPv4 Service Provider      ok (2.072s) using ipv4 ASN 55824
Find IPv6 Service Provider      timeout (16.999s)

Without DHCP

Test with IPv4 DNS record       ok (0.855s) using ipv4
Test with IPv6 DNS record       bad (0.190s)
Test with Dual Stack DNS record     ok (0.847s) using ipv4
Test for Dual Stack DNS and large packet        ok (0.775s) using ipv4
Test IPv4 without DNS       ok (0.595s) using ipv4
Test IPv6 without DNS       bad (0.009s)
Test IPv6 large packet      bad (0.231s)
Test if your ISP's DNS server uses IPv6     bad (1.482s)
Find IPv4 Service Provider      ok (1.037s) using ipv4 ASN 55824
Find IPv6 Service Provider      bad (0.234s)
0

It would appear that the DHCP server is assigning you an IPv4 and IPv6 address however there is some issue resolving IPv6 address records - perhaps IPv6 routing is not correctly enabled on the network or the queries are not being processed by the DNS server.

When curl sees an IPv6 interface address it must try using IPv6 first and then fall back to using IPv4 if required.

When you disable DHCP, you will no longer be using IPv6 so everything works nicely.

If you are running Linux, you could try disabling IPv6 entirely: http://ask.xmodulo.com/disable-ipv6-linux.html

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.