0

Looking for USB 3.0 motherboard drivers for a Compaq 15-s108na laptop so that I can put them in a bootable Windows 7 USB ISO and install.

Apparently Compaq is a subsidiary of, was acquired by, or is just a brand name owned by Hewlett-Packard. I don't know, but HP ought to be mentioned. I thought I had the drivers I needed but apparently I don't.

The computer looks like this:

http://s33.postimg.org/qdao0blxr/2016_06_12_15_37_19.jpg

Which is a little concerning as this website doesn't seem to have any USB 3.0 drivers that I can identify up for grabs.

I tried here too but I don't know if this is trustworthy/has what I actually need. There's no mention of motherboards anywhere.

According to some Linux commands I ran with a spare Ubuntu boot disk, my motherboard's "product name" is 2213, the manufacturer is Hewlett-Packard, and the version is 57.46. For all the good that probably does.

ATTENTION: Problem resolved! For anyone else with a 15-s108na looking for USB 3.0 drivers to incorporate in Windows 7 boot media with dism, this link has the one that works, and I put it into both boot.wim and install.wim: https://downloadmirror.intel.com/25476/eng/Win7_USB3.0_Creator_v2.zip

  • boot a linux and look for the HW IDs of the USB 3.0 chipset so that you see which chip you have – magicandre1981 Jun 12 '16 at 15:45
  • You mention you are looking for motherboard drivers. Are you doing this for the sake of the USB 3.0 drivers or all drivers for the motherboard? – Dale Jun 12 '16 at 15:52
  • Are you making the bootable iso for future use? you should be able to find the drivers and install them on the current running windows 7 os, and then create your ISO from the current installation and have it extract the installed drivers. Did you try this link. support.hp.com/us-en/drivers/selfservice/… – trenten Jun 12 '16 at 17:16
2

You can download various drivers for Windows 7 here > http://support.hp.com/us-en/drivers/selfservice/compaq-15-s100-notebook-pc-series/7234969/model/7485838

Look under Driver-Chipset for "Intel USB 3.0 Host Controller Driver"

  • Sorry I posted pretty much the same answer as you. I was editing my answer at the same time yours was posted. If you wish, I can delete mine as yours seems much simpler. – trenten Jun 12 '16 at 17:39
0

Go to this link.

Click on Driver-Chipset. There are 2 Drivers that are related to USB 3.0. They are both labeled Intel USB 3.0 Host Controller Driver. I would install one of them and if it doesn't work then try the next one.

First Driver

Second Driver

I hope this helps.

Alternatively, you can always try a 3rd party software to install drivers. Like Driver Booster.

  • Any input from OP would help in response to posted answers. If they don't help please post what the issue is. From what I read, the OP was unable to find the USB 3.0 Drivers to download. – trenten Jun 12 '16 at 17:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.