12

It seems that with Google Chrome Version 51.0.2704.84 (or very recently) has introduced an "elastic rubber band" effect when you try to scroll past the top or bottom of a webpage, with a mouse wheel (scroll wheel).

I am using OS X, and have never seen this behavior before in Chrome.

I find that the rubber band effect can be useful on touch devices, but I don't need it when using mice with desktop computers. When I scroll to the very end with my mouse wheel, that's typically where I want to go, and the rubber band effect is just an annoyance and delays further action.

I checked in chrome://flags, but can't seem to find a setting. Not sure.


Update 2016-09-04: This "problem" has now gone away, and the inertia setting is back to it's previous "immediate stop" behaviour when scrolling to page ends with a mouse wheel. I'm not sure what changed, but might've been a Google Chrome update. I have accepted the answer below, in case it helps somebody with a particular flavour of the issue.

  • Exactly the same problem here. I love the elastic scroll on trackpads, but it just gets in the way on a regular mouse. Would love to be able to disable it, back to how it was. (I've put a bounty on here to hopefully get some more attention to the issue, all be it a small one) – Mint Jun 22 '16 at 1:31
  • See if the solution in this article applies here : Disable elastic scrolling in OS X. See also TinkerTool for "Disable inertia" and "Disable the rubber-band effect". – harrymc Jun 22 '16 at 5:43
  • 1
    @harrymc, thanks, yeah that does work, but it disables the elastic feature OS wide, I quite like this feature, just not in Chrome with a normal mouse. – Mint Jun 22 '16 at 8:12
  • 1
    As remarked in Issue 101916 about this OS X setting : "Chrome version 23 should respect the preference". Otherwise, using an add-on to add this CSS code to every displayed future page might work. – harrymc Jun 22 '16 at 8:57
5
+50

Chrome is only obeying OS X system preferences.

Disabling these preferences is described in the article Disable elastic scrolling in OS X.

You can also use the free TinkerTool. See especially the settings for "Disable inertia" and "Disable the rubber-band effect".

If you wish to disable this only for Chrome, you will need to add this CSS snippet to every displayed future page. This is best done using the add-on Tampermonkey, which is the Chrome port for Greasemonkey.

See the Tampermonkey website for using it.

Some more references :

  • 2
    Not sure if it's correct that Chrome is only obeying OS X system preferences. When using the mouse wheel in Safari, scrolling does not produce this effect. For some reason, in Chrome the mouse wheel is behaving like a touch device. Adding the CSS code would probably disable inertia for touch pads too, right? – Winterflags Jun 22 '16 at 16:22
  • It should disable inertia everywhere. There was previously a bug in Chrome where Chrome did not obey these preferences, which it now does. I wonder whether Safari has a similar problem. There might of course be other possible answers than mine. – harrymc Jun 22 '16 at 16:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.