11

I just installed a new Kingston 300V 120GB SSD. Windows 7 Home Premium SP1 (on a Lenovo CIH61M v1.0 MB from 2011'ish) sees it and I can copy files to/from it.

But the Kingston SSD Toolbox reports:

No disks connected to system

I also discovered on the Kingston support site this:

The toolbox will not see my drive. It states "No SandForce drives found" or "No Kingston drives found". How do I resolve this?

If your computer has an Intel based system, you may need to disable the Intel RST driver and revert back to the Microsoft default AHCI driver and then run the toolbox. On an AMD based system, the AMD AHCI driver may be blocking the toolbox.

The Windows AHCI driver must be loaded. To do this, right click on Computer and choose manage. Go to IDE ATA/ATAPI controllers>AMD SATA Controller or Intel SATA Controller. Right click on this and choose Update Driver software. Select Browse>Let me pick. Choose "Standard AHCI" from the list. Then reboot the computer. Then you should be able to run the toolbox.

FAQ: KSD-100812-LSI-02

I followed these instructions and the SSD toolbox still doesn't see my drive.

Is there anything special I should be doing to get the software to see the drive? Without this software it seems you can't update the drives firmware.


EDIT July 30th

As per a comment below from @Hastur it should also be possible to update the firmware through the USB port of an OS X system (SV300S37A - Solid-State Drive SSDNow V300). The steps involved are basically:

  1. Copy the Kingston Linux image onto the SSD drive
  2. Boot from the said same drive
  3. Update the firmware using the Kingston tools.

I did steps 1 and 2 on my El Capitan system. It boots from the SSD. It runs Linux. But the tools still don't see the drive and I still can't update the firmware.


Edit July 31st

The comment from @harrymc reminded me that I have also tried the Kingston SSD Manager and that also does not see my SSD. However when scanning for the drives I see this from the SSD Manager:

Querying devices...
\\.PHYISICALDRIVE0: Detected as a secondary drive
\\.\PHYSICALDRIVE1: Detected as the primary drive
Scanning SCSI Adapters...
Device scan complete. Updating views...
Device 0 [phy=0] not available with reason code 2
Device 1 [phy=1] not available with reason code 2
\\.\PHYSICALDRIVE0: Not supported - Identify unrecognized 
\\.\PHYISICALDRIVE1: Detected as the primary drive

The Spinning disk boot drive is plugged into the SATA1 port of the mother board, and the SSD is plugged into the SATA2 port.

The Windows Device Manager reports that the

Spinning Disk - Location 0(Channel 0, Target 0, Lun 0)
Kingston SSD -  Location 0(Channel 1, Target 0, Lun 0)
12
  • Peter I'm sorry I don't understand which is your final goal, (1) "Kingston SSD toolbox doesn't see new SSD" or (2) " Without this software it seems you can't update the drives firmware"? :-) Since it is a so specific problem maybe it can help people to answer... Ps> it seems to be supported by OSX. Did you try with a Mac if it works?
    – Hastur
    Jul 6, 2016 at 7:46
  • @Hastur Thanks for pointing out the OSX support. I have been so fixated on Windows that I missed that. It is a potential option for updating the firmware, however ultimately I do want the toolbox to run on Windows as it also performs other tasks.
    – Peter M
    Jul 6, 2016 at 11:21
  • I was unlucky, I was searching for Linux support to propose you a Linux Live Usb to fix the firmware from another OS in the hope it can fix the windows (dark) side too :)... but maybe it is a path that you can try however: mount/connect the disk to a Mac if available and fix the firmware (if needed)...
    – Hastur
    Jul 6, 2016 at 11:35
  • 1
    @PeterM did this ever get resolved? Feb 17, 2019 at 18:44
  • 1
    I'm having the same problem on a brand new MSI GS65 with Windows 10. I suspect a problem with the drive, but the Kingston SSD Manager does not show it in the list. Just like OP, it "detects" it in the events, but I cannot do anything with it. Apr 30, 2019 at 13:02

3 Answers 3

5
  • Make sure your SATA drives are not set as legacy/IDE-compatible in the BIOS (OnChip SATA Type must be set to AHCI)
  • Make sure you allow UAC permissions for the toolbox when/if asked

If those conditions are met and it is not detected, it may be your SATA controller at fault. Try putting it on the primary SATA controller, not the secondary one.

3
  • I verified that the SATA type is AHCI, I have tried the SSD in every possible SATA slot on the MB (including before and after the boot disk) and still nothing. Also starting the Kingston software as Admin.
    – Peter M
    Jul 5, 2016 at 13:42
  • Starting as admin, does that mean "starting from an admin capable account and I get an UAC and pressed allow", or "right click, run ad admin" ?
    – Hennes
    Jul 6, 2016 at 12:15
  • @Hennes Using straight from an Admin account AND also trying right click etc from that account. I get UAC in both cases. The icon for the Toolbox is decorated with the Admin shield.
    – Peter M
    Jul 6, 2016 at 23:07
1

Summary of my comments on the post :

I have recommended using the Kingston SSD Manager rather than the Kingston SSD Toolbox.

From the information by the poster, I gather that the SSD is well-detected by the SSD Manager.

As both these Kingston products are mostly equivalent, the SSD Toolbox is not required. Also, Kingston documents that I have seen refer only to the SSD Manager and not to the SSD Toolbox.

As regarding the update to the firmware, the Kingston SSD Manager can do that.

However, I do not advise it if the disk is working well. Why fix it if it ain't broke ?

2
  • 1
    As per my post the SSD manager sees that there is a drive connected to the system, but it does not see a Kingston SSD connected to the system. So the SSD Manager is NOT working.
    – Peter M
    Aug 2, 2016 at 11:52
  • If you are sure that the SSD manager does not accept this SSD, then there are now two tools that fail on this same disk.I suggest contacting Kingston Support, and in the worse case asking for the SSD to be replaced.
    – harrymc
    Aug 2, 2016 at 12:00
0

Windows 7 does not always include the SATA drivers necessary to detect the SSD for every system.

If you have access to another computer with Internet access, you can go to your computer/motherboard manufacturer's website and locate the latest SATA chipset drivers. These drivers can be saved to a USB drive then loaded at that point of the installation. The SSD should be detected at that point.

Make sure the drive is being detected in the BIOS as well, if not the BIOS may need to be updated.

If you just downloaded the Toolbox and not the firmware update the update does not work properly as the plain toolbox is not linked to the firmware file to be downloaded. You can download the firmware from this location on Kingston’s official website.

After the download is complete unzip the folder and run the Toolbox from that folder. The update should work properly at that point.

It is recommended to reboot the computer after running the update if the firmware version does not change on the initial section of the Toolbox.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.