1

I am trying to get learn web application security using bWAPP (A buggy web application) which is hosted using Xampp on windows machine. I have configured the proxy (127.0.0.1:8080) in browser properly as well as getting alerts in Burp Suite.

An Instant Burp Suite Starter guide suggest that one should have the exception field ...completely empty. In firefox by default there's localhost, 127.0.0.1 values in No Proxy For: exception filed. When I remove the entries in order to follow the guide I am unable to access bWAPP login page localhost/bWAPP/login.php in browser.

If I have exceptions for localhost It works fine in browser but then Burp Suite does not pickup any traffic relating to 127.0.0.1.

Is the whole configuration faulty or am i missing something?

0

Make sure you don't write the port in Burp Suite's Target Scope host field. For example, don't write "localhost:8081". Instead, write "localhost" in the host field, and "8081" in the port field.

0

enter image description hereType about:config in Firefox browser tab , search no_proxies_on, remove the content from value

Editing the UI 'no proxy for' field should automatically change this value, but due to some reason, UI values were not syncing with this setting. I am currently debugging the root cause

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.