19

In other apps, when I hit Alt+Tab it switches to the previous app. Before I actually release the Alt key I can see a list of windows as well and the previous windows is selected. But in Excel 2010 (Professional Plus, if that makes any difference) hitting Alt+Tab and not releasing Alt shows Excel still selected, and in any case I have to hit Tab an extra time to switch to the previous application. (Alt+Tab+Tab) Furthermore, the iconized view showing my spreadsheet only takes up about 1/3 of the height available.

Needless to say this throws off my workflow because switching between Excel and another application is inconsistent, requiring an extra keystroke to switch away but not to switch back. Is this a bug in Excel, or is there some option that I need to change to get the default behavior? What's going on here?

  • How many excelsheets do you have open? Maybe its switching to a previously viewed excelsheet? – LPChip Jun 13 '16 at 17:47
  • @LPChip Just one open... I tried opening another and playing around with tabs, and while it has the same problem, they stay separate the way I would expect. – Michael Jun 13 '16 at 19:43
  • Ok, just to make sure. This is an odd behaviour though. I don't have excel with me right now to do some testing though. – LPChip Jun 13 '16 at 21:02
  • 1
    Because Microsoft – Salman A Jan 19 '18 at 21:06
  • 3
    As of Windows 10 (OS Build 17763.316), this is STILL a problem. All of the Microsoft forums threads I've seen about this only have workarounds that sacrifice some functionality, no real fixes. – ahiijny Mar 24 '19 at 2:18
26

In Excel 2010 and below,

  • Go to "Excel Options" → "Advanced" → "Display",
  • Uncheck "Show all windows in the Taskbar",
  • Click "OK" to close the Options window.

Now Alt+Tab should work fine again.

spioter says

[With] the [above] solution …, you will no longer be able to Alt+Tab between Excel documents [workbooks] – Alt+Tab will only "see" the last active Excel doc.  Work-around: with Excel active, Ctrl+Tab will switch between documents.

To revert this to the old behavior, simply go back and check the option again.


This option does not exist in Excel 2013.  teylyn says

In the 2013 version, each Excel file shows in its own window.  This is one major change to previous versions.  Each window has its own ribbon and it is no longer possible to show several Excel files in the same window.

| improve this answer | |
  • 4
    If I ignore the last step then it works, although I now have a bit more work to switch between excel windows. But if I do the last step, it reverts to the old behavior. – Michael Jul 27 '16 at 17:02
  • 5
    Doing the first two bullets fixes the issue. The last bullet creates the issue again. – Sam Sepiol Apr 5 '17 at 12:50
  • 1
    "Then go back and select it again (check the option) and click "OK"." This is unnecessary. It re-introduces the problem that the first two steps solve. – ADTC Dec 5 '17 at 23:57
  • @spioter: I just voted to reject your edit, because (1) (Most important) I found the “Steps 2 of 2” heading totally incomprehensible.  (2) You referred to “comments to the original question”, and I don’t know what you mean.  If you’re referring to your comment on the original question, you should just state that concern in the answer (i.e., in your edit).  (3) You broke the formatting.  (Hint: you have to have a blank line before the “‑ In Excel Options” line.)  P.S. Also, look into “kbd” formatting. … … … … … … … … … If you fix those problems and try again, it might be approved. – Scott Jan 10 '19 at 16:52
  • 1
    P.S. Welcome back to Super User! (It’s been three years since you last contributed, and I don’t want to scare you away again!) – Scott Jan 10 '19 at 16:52
4

My workaround for this problem is to use the old Windows XP Alt + Tab UI, following the steps described in the answer to this Microsoft support thread:

  1. Open Registry Editor (Win+R followed by regedit)
  2. Go to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer
  3. Create a new 32-bit DWORD value named AltTabSettings and set it to 1
  4. Sign out and sign back in again (or restart)

Here is what the old Alt+Tab UI looks like. When Alt + Tabbing from the Excel window, the previous application is selected after the first Alt + Tab!

The old UI is a lot more limited, it doesn't show thumbnails for the open windows, and you can't click to select windows. But since I frequently Alt + Tab between different Excel windows, and also between Excel windows and other application windows, I'd prefer sticking with the older UI over having to deal with the Alt + Tab + Tab.

| improve this answer | |
1

This was also happening to me when switching between excel and Chrome - one of my Chrome extensions was a video downloader - disabling this in chrome://extensions/ fixed the Alt+Tab+Tab issue for me. Seems a bit random but might be worth a look.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.