0

I am trying to configure my Lenovo Z70 laptop to work with Wake On LAN, but I have been unable to do so even though I have determined that the magic packets are in fact reaching my machine by making use of the Wake-On-Lan Packet Sniffer v1.2 to verify that packets sent using this website were received. I would like to send magic packets from the non-standard port 69 as opposed to the standard 9. I have configured my router to allow UDP packets on port 69 like so:

Router Port Forwarding

I have checked in the Device Manager, and I have enabled "Wake On Magic Packet" for my adapter.

Properties - Wake on Magic Packet

One thing that I have noticed is that I am unable to check the box on the Power Management tab that allows the adapter to wake the machine.

Properties - Power Management

I have checked in the UEFI settings (BIOs) to see if there is something I need to do to enable Wake On Lan, but I did not find anything.

What is the problem? How can I fix it? I am running Windows 10 Pro 64 bit edition. I am certain that the issue does not have to do with port forwarding because I have tried sending magic packets from other devices in my network, but with no success.

Edit: This article looks like it could be helpful with solving the problem of having the "Allow this device to wake the computer" box grayed out, but it describes how to resolve the problem for the "Allow the computer to turn this device off" box. Does anyone know if there is a registry key I could edit to enable the box?

-1

Generally speaking, I've been unable to WOL (even from hibernation AFAIR) any Lenovo laptop that hasn't got "Wake On Lan" entry in its BIOS Setup menu. Even when I've ticked (non-grayed) checkboxes "Allow this device to wake to wake the computer" and further checkbox about magic packet.

As a rule of thumb - for me, WOL from turned off state never worked on laptops that don't have "Wake On Lan" in BIOS Setup.

This seems to be on purpose - cheaper units ships without WOL, more expensive, business laptops comes with it.

I believe it is software-only issue, solvable by modification to system firmware/UEFI. However, the whole thing is tricky enough to prevent me from doing this.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.