5

Specifics: Mac OSX El Capitan Time Machine is from an older mac that this new mac replaced. Both running El Capitan.

The specific issue I am trying to solve is that some folders show the red circle on them indicating that I do not have access to them. I have been able to gain access to them by right clicking, choosing get info, adding the current admin user to the list of users in permissions (because they are not there) and then instructing the system to either apply the changes or make the user I just added the owner.

Now, I was able to figure out that the command line to do this enmasse is as follows: sudo chown -R user rootfolderoftimemachinebackup

I then enter the users password. I get a large number of Operation Not Permitted results but largely I this command does what I want. I am curious if someone out there can explain to me the method I would go about in gaining access to the files where it says the operation is not permitted. I have attempted the manual process explained at the beginning of this post on those specific directories. However, when I attempt to add my user to the list of users it tells me I don't have permission to do that. Well, I am the admin on this machine and the file I want to do this on resides in a time machine volume that is no longer mounted as a time machine volume. The file I am attempting to take ownership of is a windows file from a backup of a windows folder from a long time ago. It probably can be deleted, but for my own knowledge I would like to resolve this so that I know how to eliminate the problem.

One post that I saw indicated that I needed to boot with COMMAND-R and in this mode to run Terminal and disable csr. I have not yet tried this yet, but if someone can confirm the reason for the errors is because System Integrity Protection is turned on, I will turn it off.

The post I refer to is here

Thanks for any help you can provide, I will check back on this post tomorrow and answer any additional questions you might need answered to assist me in getting to the bottom of this.

Thanks again.

I have checked out the following questions to see if the answer was there.. and so far nothing.

How do I change ownership of files backed up with Time Machine

Fix Permissions on OSX Ext Disk used by Time Machine

4

I usually use tmutil to restore TM ownership after doing a manual user account restore or after migrating to a new computer. Connect the TM back-up drive. Drag the first folder inside Backups.backupdb after you type "sudo tmutil inheritbackup " in terminal app to supply the path which usually is the Macintosh shared name.

sudo tmutil inheritbackup 

Follow that with associating the last TM back-up made. Locate your TM volume then set finder view as list. Open the first folder inside "Backups.backupdb", inside should be a list of folders with TM back-up dates in their names. The 2nd to last folder should be the last TM back-up (last folder is actually "Latest" alias). Inside that folder should be the name of the volume which is normally "Macintosh HD" or whatever name if it's renamed to something else. Drag that folder below after you type "sudo tmutil associatedisk -a / " to supply the path.

sudo tmutil associatedisk -a / 

The best time to use this is before you attempt to use TM after setting-up your account on the replacement Mac or right after logging in after migration. I'm not sure if this will work since you already made manual permissions settings on the time machine back-up folders but it's worth a shot.

Good luck!

1
  • This worked for me when the same Mac had its motherboard replaced. The Mac was recognized as a new computer so it wasn't recognizing the same folder as the Time Machine backup drive. sudo tmutil inheritbackup /Volumes/Backups/Backups.backupdb/Mac\ mini and then sudo tmutil associatedisk -a /Volumes/Backups /Volumes/Backups/Backups.backupdb/Mac\ mini/Latest/Macintosh\ HD
    – bretonics
    Dec 29 '20 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.