8

Normally IMAP folders are ordered without any subfolders. So Inbox, Drafts, Sent, Junk and Deleted are within the same row/level. At some point in history these folders somehow went underneath my Inbox folder as subfolders! I cannot change these whatever I try. Searched online to no avail. There are no settings in my shared hosting (PLESK) nor my webmail (Roundcube) for changing this: everything seems fixed and nowhere are subfoldering structures available to be set or changed.

What could I try to get all the IMAP folders in one and the same root structure?

Any & all suggestions are welcome! I've donated all my credits to a bounty for tackling this question :)

nested subfolders while all should be on 1 and the same level


no special settings to set or change in shared hosting PLESK environment


Webmail shows no settings for subfolders


Webmail shows no settings for subfolders


UPDATE1 courtesy of @ZEE (thanks)

I tried these two great mail programms OperaMail and CrawlMail both showed the EXACT same structure as Mozilla Thunderbird. This rules out any malfunctioning of the Thunderbird. Digging further....

OperaMail


ClawMail


STRANGE INBOX. suffinx on all the subfolders

If I remove them (rename the paths from INBOX.Drafts to Drafts, then nothing changes! After restart they paths are back again with the INBOX. suffix. Crazy control freakish IMAP stuff!

enter image description here

enter image description here

What else could I try to change in this last diagram in Thunderbird?


UPDATE2: courtesy of @harrymc (thanks)

Currently trying your steps... todo: 1. trying a fresh new mailaccount, see if the subfoders are gone there if so move everything to there. 2. reading bugreport1 3. reading bugreport2

Adding (creating) a BRAND NEW account in Parallels PLESK (shared hosting) default normal settings (emailadderss, antivirus off, storage unilimited, spam filter off, password and thats it there are no more options!) and then configuring it as IMPA account in Thunderbird with all default settings the folder structure was automatically created AGAIN with the subfolders?!? wtf?? Does this mean its a problem of PLESK and not Thuderbird/mailprogram at this point?

enter image description here


UPDATE3: courtesy of @Alexandr Kovalchuk thanks

Even after unchecking the "Allow server to override namespace" setting still the folder structure remains subfoldered. Restarting Thunderbird shows no changes whatsoever! Sigh...

enter image description here


UPDATE 4: courtesy of @Alexandr Kovalchuk (thanks!)

Adding INBOX exactly as you said solved it. Must restart client and unsubscribe and re subscribe. This made all folders go into one root level.

enter image description here

6
  • This doesn't affect the folders in the IMAP account itself?
    – SPRBRN
    Jun 20 '16 at 10:08
  • 1
    Any news with update2 ?
    – harrymc
    Jun 22 '16 at 15:53
  • @harrymc thanks mate! I updated my answer with a new picture. Really really puzzling... Im stupified at this point... kind of a dizzy dolby surround feeling sea sickness really... I think this thing is alive! maybe we should give up as humans and let the computer win this... or?
    – Sam
    Jun 22 '16 at 21:11
  • It's a prefix, by the way. :D
    – Daniel B
    Jun 26 '16 at 9:26
  • 1
    A few minutes before the bounty ended, the reward was offered. Thanks All posters Very Very Very much for your important contributions without which this puzzle would have never been solved! Hug and embrace your intelligent helpfull minds ^_^
    – Sam
    Jun 27 '16 at 20:52
7
+100

Try to disable checkbox "Allow server to override namespace". According to thread on bugzilla, some servers indeed store those special folders under the INBOX. But client should be able to view it "as usual", i.e. at the top lever of hierarchy.

Upd. After short discussion (comments deleted) we've found solution. See "UPDATE 4" section in the question.

2
  • btw, it would be nice if you share credentials for those "test@..." mailbox, so we could reproduce bug and dig in setting for resolve Jun 22 '16 at 22:27
  • Sorry for not responding for a long time. Done. Jul 26 '16 at 15:26
2

Try to create a new profile, and if it looks normal then move the old messages to it and delete the old profile.

These two quite old Mozilla bug reports may have relevant content or workarounds :


As you report that this happens for a new Thunderbird profile and other email clients, the most likely source of the problem is in the IMAP server itself. There is probably no way to change the folder structure, but you could simulate it as described below.

From the Mozilla article IMAP: advanced account configuration :

If your email provider doesn't support creating folders that are a peer to the inbox, one workaround would be to create a child folder somewhere that's normally hidden from view and then create a Saved Search folder (aka virtual folder) whose search criteria selects all messages in that child folder. That virtual folder can be a peer to the inbox. While the messages are still physically stored in the child folder you can use the virtual folder as if it's a real folder. It will just have a different icon in the folder pane.

0
1

Ok... I've had similar problems with IMAP...

Try this,,,

download this email client -> "http://www.foxmail.com"
install it and configure your imap email account...

In the folder tree, right-click the folders you want to erase
and see if the "delete" option appears...

  • you can try the same with the old "Opera mail" client...

  • If nothing of this works...
    You can only delete the folders accessing the server via a terminal/explorer

hope it works...

1
  • Thanks and +1 for your suggestion! Foxmaill looks cool BUT its only in Chinese! (downloaded from English part of their website!) Sorry I cant read Chinese only English and Dutch ;-) In Thunderbird it is possible to delete/rename ONLY the yellow self-created folders. The default folders (Inbox, Drafts, Sent, Trash etc are not deletable nore renamable nor movable). Your suggestion brought me to here: Best Free eMailprograms for Windows 2016, Eventhough I think Thunderbird is the most powerfull still. techradar.com/news/software/applications/…
    – Sam
    Jun 19 '16 at 23:42
0

After trying out different configurations, I found this way to easily setup the correct folder structure while setting up an email account.

After entering your email address and password in thunderbird, select Manual config. -> Advanced config. -> Server settings -> Advanced and enter the following:

advanced server settings

0

Under the new outlook version this is easy.

Go to "account settings", chose your outlook email account and click on "change"

Under the new dialogue box you will see an option called "outlook root folder". Over there type "inbox" in the blank field.

Hit "OK". And you would be good to go.

Nevill

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.