0

I have one heck of a problem that I cannot seem to overcome.

I have two wireless network adapters that I am trying to use for a slightly complicated network topology. There are no routers, switches or other networking appliances used, just a laptop (Wifi capable), a telescope (yes, a Wifi enabled telescope) and an Intel Compute Stick with two network adapters.

For some background information about my equipment, the intel Compute stick and the laptop I use for remote connection are both running Windows 10 Home.

"Wireless Network Connection" is the integrated wireless adapter that comes with the computer.

"Wi-Fi" is a Belkin Nano N300 USB Wireless Adapter.

The drivers installed both support IBSS as well as Hosted Networks when I check netsh wlan show drivers.

My process is as follows:
Create an ad hoc network on "Wireless Network Connection" using the following command: netsh wlan set hostednetwork mode=allow ssid=ParamountAdhoc key=Paramount

I am met with the following response:

The hosted network mode has been set to allow.
The SSID of the hosted network has been successfully changed.
The user key passphrase of the hosted network has been successfully changed.

I then start the hosted network by using this command:

netsh wlan start hostednetwork interface="Wireless Network Connection"

The response is:

The hosted network started.

In the Network Connections window I can now see a Local Area Connection that is a Microsoft Hosted Network Virtual Adapter. Everything is working as expected so far. After a few minutes of being up, my Wirelss Network Connection will be connected to this Local Area Connection. This step is what allows me to use another device to remote connect via Team Viewer.

My next process is to connect "Wi-Fi" (the second interface and second physical adapter) to another network called ParamountMount.

To make this work, there was some setup done in advance - so I'll gloss over the steps here quickly: 1. Go to "Network and Sharing Center" 2. Click "Set up a new connection or network" 3. Double-click "Manually connect to a wireless network" 4. enter the SSID of the ad hoc network (ParamountMount as shown by "netsh wlan show networks") into the "Network name" field 5. configure security settings as Open(No Authentication) a. uncheck "Start this connection automatically" (important) 6. Click "Next", then "Close"

After the profile for the connection is created, I am able to set some parameters necessary to make the connection work as necessary:

netsh wlan set profileparameter ParamountMount connectiontype=ibss connectionmode=manual interface="Wi-Fi"

Profile "ParamountMount" on interface "Wi-Fi" updated successfully.

Again, up to this point, everything is working fine. The Microsoft Hosted Network Virtual Adapter still exists, and the Wireless Network Connection is still connected to it.

This last command kills the whole process:

netsh wlan connect name=ParamountMount ssid=ParamountMount interface="Wi-Fi"

Connection request was completed successfully.

However, the Microsoft Hosted Network Virtual Adapter stops working, and my Wireless Network Connection interface is disconnected. Any remote connections are dropped.

Wi-Fi is connected to the network "ParamountMount". I am able to then access resources on that network, however, with no way to actually access to computer (intended to run as a headless remote machine) that's connected to "ParamountMount" it's completely useless.

Now here is what really confuses me: When I attempt to recreate the ParamountAdhoc network using the same start hostednetwork command as above, I get this new error:

The hosted network couldn't be started.
The group or resource is not in the correct state to perform the requested operation.

When I check device manager to see if the virtual adapter has somehow been disabled, I see that it is running. There are no events indicating a crash in Event Viewer.

If I disconnect "Wi-Fi" from "ParamountMount", only then am I able to recreate the "ParamountAdhoc" network.

What am I missing, or doing wrong that when connecting to a network with one interface, it closes the connections of another? They should be mutually exclusive, right?

Thanks for reading all of this. I hope I didn't leave anything out, but let me know if there is more information that I can provide.

  • The command netsh wlan start hostednetwork interface="Wireless Network Connection" don't support parameter interface="...", windows always chose wireless adapter by self – vlk Jun 28 '17 at 7:38
-1

You also need to enable ics on the adapter with the internet connection and share it with the adapter hosting the the ad-hoc connection

  • While this may answer the question, please consider adding how-to do the steps (where to find, for example). Your answer is short and can be improved by adding more explanation on the steps required (and why it would work, that will be great!) – Vylix Jul 2 '17 at 3:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.