0

As documented in this question, I need to make a static ARP entry on my router. My router is a Verizon AC1750, and I am facing some difficulty along the way. From what I can gather from the router's user interface, I cannot add a static ARP entry from it, however I have read that it is possible to add such an entry by using telnet to log in to the router.

This article contains the following screenshot showing that telnet can be enabled on a Verizon router.

Enabling Telnet on Verizon Router

Seeing this, I decided to log in to my router and enable the option, but when I got to the "Local Administration" page on my router, this is what I saw.

Enabling SSH on Verizon Router

I have no problem with using SSH instead of Telnet, especially since SSH is certainly more secure, but SSH does not seem to be working properly. When I log in to my router via SSH, here is what I see.

Loggin in to Router via SSH

I have limited experience with SSH, although I have used it a little bit. When this terminal was presented to me, I did what I usually do when I see a console and don't know what to do. I typed help, which returned a very unhelpful error: -sh: help: not found.

I am now lost and have no idea where to go from here.

1

You got to the command line (command interpreter shell) of a stripped down copy of Linux or other Unix-like OS.

Most Unixes have an arp command for working with the ARP table. To enter a static ARP mapping for your host, you most likely need to type:

arp -s IPAddress MACAddress

(Replace IPAddress and MACAddress with the correct addresses of the machine you want to always be able to wake.)

I believe most Linuxes still have an arp command even though it's been deprecated in favor of the ip command. If not, look into ip neighbor add …

That is, something like this:

ip neighbor add 192.168.0.200 lladdr 00:11:22:33:44:55 dev eth0 nud permanent

Note that setting static ARP entries this way is not persistent across reboots of your router. How to make it persistent in your particular router's Unix-like OS is hard to say, but since it's probably a stripped down Linux similar to OpenWrt, DD-WRT, Tomato, etc., you should be able to find suggestions from other forums that may work on your box. Many Unix-like OSes have boot-time startup scripts (known as "run command" or rc scripts) in /etc. So you may be able to add that arp -s … or ip neighbor add … command to a file like /etc/rc.local to make sure it gets run every time your router boots.

1
  • Neither of these commands are working. When I try the arp one, I get the error -sh: arp: not found. I tried the command again with an sh at the beginning of it, so sh arp, and I got the error sh: can't open 'arp'. The same thing happened when I tried to use the ip command. – DaveTheMinion Jun 16 '16 at 15:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.