Recently I installed VirtualBox (and the networking support that comes with it). Everything worked great, it's a lot nicer than the old VM I was using.

However, ever since installing, I can no longer remote desktop into my machine!

I've checked to make sure that my network IP address hasn't changed, and that my router is still set up to allow remote desktop to my pc, and it is, however, I still can't connect.

Has anyone encountered this problem? How can it be resolved?

  • You can't remote into the VM or into the host? – Chris Thompson Jul 22 '09 at 16:36
  • The host, even when virtualbox is not running. – TM. Jul 22 '09 at 16:45
  • Are you using NAT translation or bridged mode? (Just trying to narrow down this as a networking issue.) – Michael Todd Jul 22 '09 at 16:51
  • (And, no, it shouldn't matter, but obviously something's changed and VirualBox does add a network device.) – Michael Todd Jul 22 '09 at 16:53
  • 1
    Apparently others are having this issue as well: forums.virtualbox.org/viewtopic.php?f=6&t=16825 – Michael Todd Jul 22 '09 at 16:57

Do any of your VMs have remote display enabled? This binds by default to the standard Windows remote desktop port (3389). If a VM is using this port, Windows won't be able to use it for remote desktop. See the manual for more discussion on how to change the port.

  • Does this take over the port even when no VMs are running? Seems odd if it does. – TM. Jul 22 '09 at 21:54
  • I updated my install to 4.3.6 r91406 and one of my VMs was changed from no remote - to remote on the default windows port. Ridiculous. Problem exhibited at boot - vm was not running, nor was virtualbox app even open. – Jim Ford Feb 10 '14 at 12:27

I hit the same issue - adding an answer here because the cause and solution for me was different to the one listed above.

I found that the "VirtualBox Host-Only Network Adaptor" prevented me from using remote desktop into the host. It also disrupted corporate network backup access to that host.

The solution for me was to follow http://brianreiter.org/2010/09/18/fix-virtualbox-host-only-network-adapter-creates-a-virtual-public-network-connection-that-causes-windows-to-disable-services/

That article describes a registry tweak to set *NdisDeviceType to DWORD value 1 in the adaptor settings for the VirtualBox Host-Only Network Adaptor. Network adaptor settings can be found below HKLM:\system\CurrentControlSet\control\class\{4D36E972-E325-11CE-BFC1-08002BE10318} in the registry.

*NdisDeviceType is documented on msdn (http://msdn.microsoft.com/en-us/library/ff557037%28VS.85%29.aspx); the required value of 1 is used to indicate that the network adaptor doesn't connect to an external network. Without that value set, the presence of an 'unidentified network' leads Windows to be more aggressive about firewalling, hence the disruption I saw to remote desktop and backup access.

Note that I have to reapply this change each time I upgrade VirtualBox. Sigh.


I also installed VirtualBox remotely and it broke my Remote Desktop connection.

My experience is this: The Windows firewall seems to have been resetted.

One solution I can give you is this: Connect your keyboard, mouse, and your display to a remote machine and re-setup the firewall again. In my case, my HDTV does not have a VGA input and I don't have a VGA monitor, so I have to put in my video card with DVI-to-HDMI adapter to control my server directly.

It's a pain, but it seems to be the only way UNLESS there's a way to remotely configure the firewall (but a firewall is a firewall and I doubt this will happen).

PS: While in the subject of firewall and in a different subject from Remote Desktop and VirtualBox, from my computer in an internal network, I tried to access my website in my server and port 80 has been blocked. This is after I install VirtualBox with networking support.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.