22

I would like to disable the autocomplete things that come up on the iTerm, as shown in the picture below:

enter image description here

I would like to get rid of the blue hint that comes up when I start typing a command similar to the one that was previously executed.

  • 1
    What a hopeless feature that is. – David Rhoden Oct 12 '17 at 4:58
42

You can disable the auto command completion by navigating to the following menu:

View > Auto command completion

  • 4
    I passed by this so many times trying to find out how to do this 😞 – Thomas McCabe Dec 10 '16 at 2:02
  • 5
    This would be a useful feature if I could use [Tab] to get through the suggestions, rather than [Tab] causing a bell and having to use [Enter] to go through the selections. And to have it not be configurable? terrible. They did everything else so well, too! – Metagrapher Jan 4 '17 at 23:21
  • 1
    Thank you, this was driving me crazy. I was making multiple changes to my iTerm2, and I initially thought it was zsh and oh-my-zsh triggering this. Lesson learned :) – danyim Jan 30 '17 at 1:29
  • 1
    I think I went through every option in preferences to find this haha. Thank you :) – Matthew Cawley Aug 5 '17 at 23:24
  • 1
    I've been looking for this for ages! Thank you! – Sergio Acosta Aug 8 '17 at 17:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.