225

I have a process that I can't kill with either Task Manager or Process Explorer - I get the error "Access denied". The process isn't a Windows executable.

How can I kill it? Is there some tool I could use to override this protection?

I'm using Windows 7, 64-bit edition.

9
  • would it be asked too much telling us which process you want to terminate?
    – Molly7244
    Feb 17, 2010 at 22:52
  • 4
    run command prompt as administrator. use taskkill /im <your process.exe> /f to end the process Jun 15, 2012 at 12:08
  • 2
    @tumchaaditya: taskkill /im <process>: The process can only be terminated forcefully. taskkill /F /im <process>: There is no running intance of the task. :( TaskMgr as admin also can't kill it: Access is denied. May 16, 2014 at 22:38
  • 11
    Would it be necessary to ask a separate question to ask why as an administrator of my own system I am "not allwoed" to kill a process on my own system? I could see a "warning" at most: "hey, if you kill this process, this, this and this will happen, would you still like to continue?"
    – IT Bear
    Sep 21, 2014 at 5:19
  • 1
    For what it's worth, I used procexplorer to look at the task and I saw that the parent task was explorer.exe. I killed explorer.exe and then the task went away. Nice and simple in the end. I'd put this up as an answer, but it's not letting me for some reason. Dec 1, 2015 at 8:15

10 Answers 10

116

Kill a protected process?

http://processhacker.sourceforge.net/index.php

Works on Windows Server without admin rights! Yammie! :)

11
  • 7
    Thanks! I was able to kill the "access denied" process with process hacker, this is great advice, this should be the chosen answer for this question. Thanks for also letting me know about this great software, I was unhappy with process explorer for a long time, now I've found a great replacement.
    – KoKo
    Oct 26, 2012 at 18:52
  • 28
    Did not kill my process, but at least it gave a reason except "Access Denied" (which Task Manager and Process Explorer dit not: Unable to terminate OUTLOOK.EXE (PID 7588): An attempt was made to access an exiting process.
    – thomasa88
    Aug 19, 2013 at 15:00
  • 3
    Process Hacker won't kill the Symantec DLP process [edpa.exe]
    – PeterX
    Jul 2, 2014 at 1:50
  • 1
    It may also be possible to simply start Process Explorer as an administrator in order to gain rights to kill such processes. Worked for me anyway.
    – bames53
    Mar 21, 2015 at 5:45
  • 5
    I'm still getting an error with Process Hacker: "Unable to terminate ... An attempt was made to access and exiting process." Oct 11, 2016 at 4:43
19
  1. Download "Process Explorer".
  2. On the process properties view, select the security tab.
  3. Press the permissions button.
  4. Press the advanced button.
  5. If necessary, add yourself or a group you belong to.
  6. Edit your permissions to include "Terminate". (you will need to already have the "Change Permissions" permission, or you are out of luck.)

alt text

In general, the need to kill tasks means somebody is not doing something correctly. I'd look for another solution to whatever problem you are facing. Perhaps if you told us more about that we could find a more graceful option?

7
  • 14
    Permissions button is grayed out, even though I'm an administrator and I'm running Process Explorer elevated.
    – cheesus
    Feb 20, 2014 at 7:57
  • 2
    This is not work for me to kill AVGUI.exe process but i did it using Process Hacker Mar 4, 2014 at 9:18
  • 2
    My "Permissions" button isn't grayed out, but the dialog that comes up (in Windows-8) doesn't have all those available. Just 'Full', 'Read', 'Write' and 'Special'. Jun 8, 2015 at 1:38
  • 3
    > the need to kill tasks means somebody is not doing something correctly. Yeah, namely the programmers who wrote the damn thing.
    – Kaz
    Feb 5, 2019 at 1:05
  • 1
    This solution did not work for me. My account has the kill permission, but the process cannot be killed. Jul 9, 2020 at 10:16
18

The taskkill and powershell (kill) methods didn't work for me; it still said Access Denied.

I had better luck with this:

wmic process where name='myprocessname.exe' delete
7
  • 34
    "Access denied" using this method too. Apr 22, 2017 at 18:54
  • 1
    This is working like a charm.
    – Hamza Anis
    Mar 23, 2018 at 10:56
  • 11
    I had to type wmic process where "name='myprocessname.exe'" delete. Otherwise I would get an Invalid query error. At the end I still get an access denied error. Jul 30, 2018 at 7:30
  • 1
    Instance deletion successful. and yet it remains :(
    – ken
    Oct 22, 2019 at 2:39
  • 2
    @MemetOlsen An alternative syntax is processid=1234. However, I also still get “ERROR: Description = Access denied”.
    – binki
    Feb 26, 2020 at 14:17
14

None of the mentioned above tools helped in my case.

See https://techcommunity.microsoft.com/t5/windows-blog-archive/unkillable-processes/ba-p/723389.

Mark Russinovich shows there that there are cases when process can be almost impossible to kill.

2
  • Link is broken .
    – tchelidze
    Nov 13, 2020 at 12:29
  • 1
    @tchelidze, fixed
    – Vadzim
    Nov 13, 2020 at 13:53
7

Are you on a privileged account? Generally when you receive the "Access Denied" error even on an account with higher access, it is usually because you are trying to kill a service which is critical to the system's operation. Some applications on the other hand, such as VMWare, also implement their own "process protection", even for processes which are not vital to system operation.

If you are on a privileged account, you can give Sysinternals PsKill a shot, I've used it in the past to kill processes that gave me similar error messages. Be careful what processes you're killing though, it may make your system unstable.

3
  • If i am taking down my processes, will it be still unstable ? Jan 24, 2012 at 13:13
  • However pskill can't kill any process. In my case it can't kill nginx wrapper that is not critical process. It's a service but not a usual process.
    – sergzach
    Feb 19, 2012 at 11:42
  • After running this, it told me it worked even though it didn't..
    – Akaisteph7
    Feb 28, 2020 at 22:29
6

You just need to give process explorer administrative privileges, no need of adding any account or not (if you're already an admin). There is no need of telling which processes to terminate or not or installing any other process manager (even I love Process Explorer).

Either:

  • Right-click and "Run as administrator"

  • Go to properties and then compatibility and select "Run as administrator"

Now it'll never say access denied.

3
  • 31
    Um Yea, it can still say "access denied". If the process is started with security flags that alter the terminate permission in the process ACL, you won't be able to terminate it until you can change that permissions on the process. Antivirus process often do this on purpose (mostly just to be annoying), as it wouldn't be hard for malware to get around this usually. ala processhacker.
    – DanO
    Aug 16, 2012 at 17:16
  • 9
    does not work for me.
    – peter
    Apr 14, 2014 at 9:20
  • 2
    Cannot shutdown MsMpEng this way in Windows 7/8/10. May 21, 2018 at 21:13
4

Not sure the reason but using Sysinternal's Process Explorer and clicking at "Show Details for All Processes" from File menu solved the issue and allowed me to kill the service. Perhaps it switches to Admin mode only then.

1
  • It does exactly that. That option makes it re-launch itself with elevated permissions (if you have them).
    – DanO
    May 31, 2018 at 18:32
2
  1. Open Task Manager. Go to the Process Tab.
  2. Right click on the process and click on Properties.
  3. Click on the Security Tab and then click on Edit.
  4. On the Permissions window click on the Add button to open the Select Users Group or Groups window.
  5. On the Select Users or Groups window you can enter the usernames of the accounts you want apply the restrictions.
  6. Select your username and set the permissions to deny/allow by checking the checkbox under the deny/allow option.
  7. Click on Apply and then Ok.

via

8
  • 1
    I am an admin and I have full control. Feb 20, 2010 at 4:56
  • 20
    Usually when you can't kill a process you can't change its permissions either
    – skan
    Jan 10, 2012 at 0:43
  • 3
    Hmm I tried it, but when I pressed Apply, it told me "ACCESS DENIED"
    – Jet
    Jun 24, 2013 at 10:16
  • 1
    Changed the permission, did not work Feb 9, 2016 at 9:12
  • 4
    Erm, what? This would change the permissions of the excutable file, not the running process instance, so it seems totally irrelevant. Apr 13, 2017 at 12:48
1

Try using APT(Advanced Process Terminator), kills any process easily.

1
1

It is also possible to kill commands using the Windows PowerShell, use get-process to list the processes running and then use stop-process with the ID of the task to kill it. Stop-Process.

get-process Unkillable.exe
stop-process 1234

You may find you need to launch the Windows PowerShell specifically as an administrator.

1
  • 4
    As of late 2019, this method and every other mentioned here fails to kill (or allow me to query the handles or anything else of) MsMpEng.exe, for one: I have no controlling access to this process, which I don't much like. Previously, if I saw the thing churning when I didn't want it to, process hacker would kill it. Now, nothing will. Have microsoft done something to this program to make it unkillable? Is there any way around this now?
    – Luther
    Jan 2, 2020 at 8:47

Not the answer you're looking for? Browse other questions tagged or ask your own question.