22

When I plug in my external hard drive (again, NOT USB stick), and right click on the icon in This PC, there is no option to eject the drive.

enter image description here

There is a system tray option to "safely eject" it, but that doesn't work at all.

enter image description here

The only way for me to remove it at the moment is to shut down the PC.

I am not looking for a third party solution (cuz they don't work anyway - I've tried a range: Unlocker, the Quickandeasysoftware one, etc..). I've also disabled drive indexing.

And before you mark this as a duplicate almost ALL of the internet / SU articles are either on USB sticks, or on this shutdown method (e.g. Can't eject external USB hard drive in Windows 10)

I just want to know if this is possible (it should be right?), and if so how.

8
  • Check what application is accessing your HDD and close it. If you can't/don't want to close that application search for "Process Hacker" and "Find" all handles to your HDD (search for something like "C:\") and close them.
    – GiantTree
    Jun 16, 2016 at 20:21
  • processhacker.sourceforge.net " A free, powerful, multi-purpose tool that helps you monitor system resources, debug software and detect malware." It's basically a replacement for the fairly limited Task Manager and works great.
    – GiantTree
    Jun 16, 2016 at 20:24
  • @GiantTree ok tried that, and sure enough Windows Explorer has a handle to the drive. how to I overcome this? I've already turned off indexing Jun 16, 2016 at 20:40
  • Close any Explorer window to it and/or right-click the handle and close it.
    – GiantTree
    Jun 16, 2016 at 20:42
  • @GiantTree do you know what's causing this? I wunna get to the root of the issue; if you don't then thanks anyway for the link Jun 16, 2016 at 20:45

5 Answers 5

18
  1. Click Windows icon in task bar.  Click on Run…
  2. Type:

    RunDll32.exe shell32.dll,Control_RunDLL hotplug.dll

  3. Press the Enter key or click on “OK”.
  4. In the “Safely Remove Hardware” dialog click on the device you want to remove, and press Stop.

(from answers.microsoft.com)

6
  • 8
    I found a better answer here: You should be able to eject these drives by clicking on the “Safely Remove Hardware and Eject Media” icon in the system tray and selecting your USB drive to eject it.
    – nak
    Jul 30, 2018 at 20:43
  • 2
    You can put the Run command line above in a shortcut on your desktop so that it is easily available. nak's comment doesn't work on Windows 10.
    – Ron
    Oct 2, 2018 at 20:44
  • 3
    this is shown in the question to not work.
    – ths
    Nov 20, 2018 at 20:19
  • 1
    It solves my problem. I am using Windows 10 and somehow the eject tray icon didn't show up in the tray today. Aug 27, 2019 at 2:14
  • 1
    This doesn't works. I'm getting message that "device is not removable and cannot be ejected or unplugged." Although it's 100% removable hard drive connected by USB. Apr 20, 2023 at 19:42
2

I found that if you go to Windows/Settings/PC Settings/Devices/Other Devices and click on the name of the device, there is a button to remove device.

1

In the resource manager check to see what's using that hard drive. Control Panel/Administrative Tools/Resource Monitor. Or on command line "perfmon.exe /res". perfmon window Go to the Disk tab and see what Processes have Disk Activity on that drive. This won't solve your problem as windows will probably never put in a nice right click, but it may help figure out what's happening and let you do it without shutting down or sleeping.

1

Open up Computer Management, mark the drive offline, it will be then safe to eject.

2
  • How do I mark a drive as offline?
    – desbest
    Oct 12, 2020 at 17:34
  • Good, but still not real eject Apr 20, 2023 at 19:39
-2

At this time, Windows 10 does not treat a memory stick on the USB port the same way it treats a Hard Drive. One option is to turn off the computer. That is, go to the Power > Shut Off. An alternative mentioned by someone else is to go to Sleep mode and then wake up. That does not do any good if I just want to remove the USB connected hard drive and continue my other computer stuff. Microsoft has not fixed this problem. Note, it is an interface problem where the operating system (Windows) should manage this. Sorry, people, Microsoft sees no urgent need to correct their operating system bugs. UNIX and Linux do not make these errors because programmers who care about the user have removed many problems Microsoft programs into their operating systems. In review, Shut Down the computer. Then unplug the USB to your External Hard Drive. There are no other solutions.

2
  • 8
    Please stick to facts and leave out the opinion. Nov 22, 2017 at 2:58
  • Agreed, would be a much better answer without without the commentary. When all other options fail, restarting should work as well, to allow clicking "remove", or shutting down as you mention. I had an Ext. HHD, where the very act of ejecting triggered "System" into writing to log files on the HHD (now in use), for no obvious reason, other than because I had indexed it, thinking it would help me find what I was looking for faster... removing it from the indexing list had no effect, because that requires a restart, (but M$ doesn't tell you that either). Worse yet, the activity light was off too.
    – tahwos
    Mar 15, 2020 at 11:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .