My PC is running Windows 10 64 bit. I don't know why it is not getting an IP address from the DHCP server; I am sure it's a configuration problem. It is getting an IP like 169.…

Here is what I have tried:

  1. Changing router.
  2. Reset TCP stack and winsock.

To check whether it a hardware issue, I booted Ubuntu and it worked perfectly.

In Windows, when I assign static IP in DHCP range, it works. But it does not get IP automatically from DHCP. ipconfig /renew shows DHCP connection timed out.


I found this error in some Intel 82579DM network adapters, and I solved restarting DHCP Client service with an administrative prompt:

net stop dhcp
net start dhcp

Or with the services.msc interface.


Restarting DHCP Client from services solved my problem. enter image description here


I know this is old but it happened to me today after we changed our router (SSID stayed the same).

My advice before going through a ton of troubleshooting steps is to delete your network in ‘manage known networks’ and then reconnect.

My Story

I went through all the tips from the answers here but none worked. I then assigned an IP address within my routers range and my computer connected to the internet fine but I noticed my home network had a ‘2’ at the end of it when connected even though that is not what my router broadcasts

Seeing this I then Deleted my SSID’s in ‘manage known networks’ once this was done I re-connected to the network absolutely fine with no issues and DHCP picked up an IP address fine.


I foun this error from 2016-12-07 on. Detected on Lenovo M90 with Intel 82578DM adapter. Fastest solution was to set fixed IP on adapter. The solution with alternate configuration didn't work.

  • 1
    Hi, your answer would be more useful if you'd explain more on what do to exactly and where to do it. Read How to Answer to learn about providing good answers. – user 99572 is fine Dec 24 '16 at 15:30

Somehow the command "net stop dhcp" followed by "shutdown /r /f /t 0" and doing almost all the stuff described at "https://support.microsoft.com/en-us/help/10741/windows-10-fix-network-connection-issues" fixed the problem for me. I don't understand how and why. I didn't understood how the problem occurred neither but this is another story. Thanks for the help everyone.

  • The author's problem has nothing to do with the Windows 10 bug introduced by KB3201845. – Ramhound Jan 4 '17 at 22:22

Encountered the same on a computer I was called to. Turned out that the driver for the network card (realtek 8168) wasn't installed. Windows 10 did recognize the card, but never fully initialized it. So look up the brand and type of the network chip on the motherboard and download & install it.


Solution: Enable "DHCP Client" in "Services". That's it. Mine was set to "disabled". Remember that this is not "DHCP Server". You are not switching your PC to serve IP's. You are setting it up to listen for an IP address.


You could try what helps with a current Microsoft Windows 10 bug. Microsoft tells to press Shift and restart your computer: To accomplish this you could also type ´shutdown /r /f /t 0´ in your console.

  • The author's problem has nothing to do with the Windows 10 bug introduced by KB3201845. – Ramhound Jan 4 '17 at 22:22
  • And did the hint not help out? – Jaleks Jan 6 '17 at 7:54
  • Your hint is for an entirely different problem. You should edit your answer so it addrsss specifically the problem the author had – Ramhound Jan 6 '17 at 12:55

I just came across this issue on a Lenovo Edge E530. It was happening on both wireless & LAN.

Followed Tobia's suggestion for stopping & starting DHCP Client service. When stopping the DHCP Client service via services.msc, it gave me an error message, but the service was stopped. When I restarted the service, problem was solved.

I did not have to do anything with the network stack.

  • 1
    Your problem is entirely different the author's problem. You need to simply update to the current build of Windows 10. See this answer for more information. This also doesn't actually answer the author's question but instead ask's your own question within the body of an answer. – Ramhound Jan 4 '17 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.