7

My Laptop has dual graphic card:Intel HD Graphics 530 and GTX 970m and I usually connect an external monitor to it, setting external monitor (noted as Monitor 1) as main monitor. Both monitors are on. But these days I found that when I play video fullscreen on chrome, the monitor will turn to black but audio goes on, ie. my computer cannot render video correctly. I tested several times and got some info:

  1. When I set Monitor 2(internal monitor of laptop) as main monitor, the video is ok when fullscreen, no matter which screen you drag the chrome window into.

  2. When the HD 530 is banned in Device Manager, ie. only GTX 970m working, it also works well.

  3. I tried disabling Hardware Accleration as some solution instructed but seems this issue remains unsolved.

  4. Playing video file (.mkv, .mpeg, etc.) with video player (Windows video player, Potplayer, .etc) never meets black screen.

  5. Rolling graphic cards' drivers back has been tried but not working.

  6. Edge as well as IE has same problem as chrome, so I guess the real problem is about video cards indeed.


Addition:

I seem to recall that weeks ago when I played web video fullscreen on Monitor 2 (which is not main), Windows crashed and went BLUE SCREEN. Though if Monitor 2 set as main the error would not occur according to my tests.


I really want to know why and how to fix. Thank you.

  • Does it work on Firefox for you? I have a GTX 870M with the same issue. – asulaiman Jun 21 '16 at 17:12
  • 1
    I have also found that it works when i duplicate my two screens. – asulaiman Jun 21 '16 at 17:19
  • Firefox and Edge/IE meet same problem. – Varg Nord Jun 28 '16 at 7:49
  • What OS are you using? I have the same problem on a msi gs70, --->disabling hardware acceleration in chrome fixed this<--- I think we may need to force chrome to use GTX 970 (right click before start, set gtx970). BTW What ur laptop model? =) I recognize that new 6th gen processor graphics – Pathfinder Aug 6 '16 at 6:01
  • 1
    Thanks for detailing this question and its potential solutions. I was able to solve it by turning off hardware acceleration in Chrome. – xji Jan 14 '17 at 13:36
4

Normally, the error should disappear when you disable hardware acceleration. If the error is caused by the graphics card. Update your graphic hardware to the newest date.

Chrome:

Disable Chrome HA

Firefox: Firefox

Internet Explorer:

enter image description here

Alternative try this:

 1. Open Regedit:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\

 2. Search for you Intel graphics card:
It is very likely the 0001 entry.
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{"Something!!!"}\0001

Right Klick -> New Dword -> @chrome.exe -> Value 1

protected by random Jun 21 '16 at 18:45

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.