In Windows (XP at least), when there are two or more keyboard layouts for the same input language, pressing Ctrl+Shift switches the keyboard layout. Where can this be disabled or changed to another keystroke combination?

A similar feature is changing input languages. Alt+Shift is the default keystroke and that can be changed and disabled through the Regional and Language Options in the Control Panel. The keyboard layout switch (Ctrl+Shift) cannot be found in that panel.

  • 3
    Gosh I wish Microsoft would have made this Right-Shift, & Right Ctrl – Jonathan Jul 3 '16 at 19:51

10 Answers 10

up vote 92 down vote accepted

You were very close to the solution of your problem ;)

Control Panel -> Regional and Language Options -> Languages tab -> Details...

There, you can edit the hotkeys to change input languages. If you press the Change Key Sequence... button, you will be able to change (disable) the hotkey which switches keyboard layouts (that Ctrl+Shift combination you mentioned).

  • 7
    Just to extend the answer. The option is hidden within the "Change Key Sequence..." dialog when selecting the first row in the the two-column "Hot keys for input languages" in Advanced Key Settings. – Pedro Palhoto Feb 15 '10 at 13:06
  • 2
    @Pedro - tricky indeed. I went to this dialog this morning, searching for the answer, and stopped just before, because the "change key sequence" was looking like referring to the currently selected item only. No indication about this ctrl+shift. – Gnoupi Feb 15 '10 at 13:31
  • 2
    Hopefully now sanity can be restored. – An̲̳̳drew Feb 9 '11 at 21:02
  • 4
    For those searching an answer for Windows 8: superuser.com/questions/604790/… – KooKiz Jan 18 '14 at 21:09
  • 2
    Aaaaand, on Windows 10 they have hidden this once again. But whereÉÉÉÉÉÉÉÉÉÉ – tbone Feb 14 at 2:35

It has moved again in Windows 8.1 and Windows 10. From the desktop:

  • Settings (with the mouse hover at bottom right, then click cogwheel)
  • Control Panel
  • Clock, Language and Region
  • Language (or "Add a language" or "Change input methods" - all go to the same place)
  • Advanced settings (in the left margin)
  • Change language bar hot keys (a hyperlink about halfway down) enter image description here
  • Advanced Key Settings (tab)
  • Change Key Sequence (button)

There you have (limited) options to change or disable the hotkeys for switching input language or keyboard layout.

  • 10
    Note that it'll probably look like there isn't a ctrl-shift keyboard shortcut to change keyboard layouts, but actually there is. It's hidden under "Between input languages", it looks like that's just alt-shift to change language, but actually that item in the list also includes ctrl-shift to change keyboard, hidden – user568458 Jul 31 '16 at 22:27
  • 1
    that comment from user568458 really saved this one for me. I almost missed it - it would be great if this could be incorporated into the answer. – Simon Zyx Dec 6 '17 at 13:22
  • Windows 10 has removed the ability to change this. – tbone Feb 14 at 2:38
  • 1
    @tbone I am using Windows 10 Home version 1709 build 16299.248 and the options are still there for me. – Richard Feb 16 at 3:23
  • The options are there for me in Windows 10, but disabling them has no effect :( – Xavier Shay Mar 12 at 5:38

This is different in Windows 7. It's in the same Region and Language interface but you do this.

  • Keyboards and Languages tab
  • Change keyboards... button
  • In the popup go to the Advanced Key Settings tab
  • Here you can choose the Between input languages item in the list then press the Change Key Sequence... button
  • Change to Not Assigned radio buttons
  • Click Okay 3 times, then voila :)
  • 2
    Thank you for this... was driving me nuts because CTRL+SHIFT+CLICK opens things up as administrator, but the CTRL+SHIFT would cause my keyboard layout to change. – Jason Down Jan 31 '13 at 19:04
  • 1
    Thanks mate, really helpful in VS where ctrl + Shift + something else do lots of stuff – Ignacio Soler Garcia Jun 3 '14 at 10:31
  • Also worth mentioning for Visual Studio purposes @IgnacioSolerGarcia, if you run VS as admin you'll have to change the settings for the Admin user too...I haven't figured that part out though... – drzaus Oct 31 '17 at 18:02
  • ...figured it out -- literally switch users to that Admin account and change settings there, then sign out and back to your usual account, then probably restart VS. Bliss – drzaus Oct 31 '17 at 18:13
  • Even though I have it set to Not Assigned it still changes the layout when I press ctrl + shift :( – Vivek Athalye Aug 13 at 16:19

In Windows 10:
Start > Settings > Time & Language > Region & Language > Additional date, time and regional settings > Change input method > Advanced settings > Change language bar hot keys > Change Key Sequence

  • 1
    Wow, amazing you were able to find this!! But now that Iève gotten there, what do I doÉ - that is supposed to be a question mark by the way. This situation is hilariously depressing. – tbone Feb 14 at 2:47
  • Windows 10 is tricky because they changed it from versions to version. I got as far as the Advanced settings above, but did not notice the Change language bar hot keys... thanks! On other Windows 10 versions, you'll find the same thing under Region and language settings > Advanced Keyboard Settings > Language Bar Options > Change Key Sequence... – GaspardP Aug 26 at 4:52

Skip the UI. It'll just keep changing for no reason. Run this to get to the Text Services and Input Languages dialog:

rundll32 Shell32,Control_RunDLL input.dll,,{C07337D3-DB2C-4D0B-9A93-B722A6C106E2}

Then Advanced Key Settings tab → Change Key Sequence… button → choose Not Assigned for both, and click OK, then the other OK.

  • 1
    Yeah, it moved again in the April 2018 build of Windows. I think that’s the sixth place it’s been. – Chris Morgan Jun 19 at 1:24
  • This is awesome – Name McChange Jul 13 at 15:11

The registry key controlling this is documented here: http://technet.microsoft.com/en-us/library/cc976564.aspx

If you're like me, you will also want to disable ctrl+shift hotkey on the logon screen, so add the reg value mentioned to the HKEY_USERS.DEFAULT\Keyboard Layout\Toggle key.

As will said, you can change it through registry, it is documented here: http://technet.microsoft.com/en-us/library/cc976564.aspx

If like me you don't like clicking too much, you can switch it off fastly, typing this in Start Menu/Run:

powershell -Command Set-ItemProperty -Path 'HKCU:\Keyboard Layout\Toggle' -Name HotKey -Value 3

This is how to disable it in the standard edition of Windows 8.1, for any other edition you might be better of manually locating the setting in the Control Panel.

Save the below as a .reg file and run it, the hotkey will be disabled immediately without the need for logging off. Alternatively, follow the instructions in the code comments to set it manually through the Control Panel:

Windows Registry Editor Version 5.00

; Note: This is for Windows 8.1 - the location of the settings/keys change with different Windows versions
; CONTROL PANEL:
; Control Panel->All Control Panel Items->Language->Advanced settings->Change Language Bar Hot Keys->Advanced Key Settings->Change Key Sequence...->"Not Assigned"
; WINDOWS REGISTRY:
; Primary Key: [HKEY_CURRENT_USER\Keyboard Layout\Toggle]
; Optional Secondary Key (might be needed for Windows logon screen): [HKEY_USERS\.DEFAULT\Keyboard Layout\Toggle]
; Values: "Language Hotkey" and "Layout Hotkey"
;1 = Key Sequence enabled; use LEFT ALT+SHIFT to switch between locales.
;2 = Key Sequence enabled; use CTRL+SHIFT to switch between locales.
;3 = Key Sequences disabled.

[HKEY_CURRENT_USER\Keyboard Layout\Toggle]
"Language HotKey"="3"
"Layout HotKey"="3"

[HKEY_USERS\.DEFAULT\Keyboard Layout\Toggle]
"Language HotKey"="3"
"Layout HotKey"="3"

On Windows 7 I opened the "Region and Language" tool. Clicked "Keybords and Languages" tab then clicked "Change keyboards" button. Then in the "Installed services" tree list I selected the keyboards I didn't want (French) and clicked "Remove.

In Windows 10 from April 2018 onwards, the Control Panel step has been removed; you can get to the final dialogue box (“Text Services and Input Language”) directly from the Settings app:

Settings → Time & Language → Region & Language → Advanced keyboard settings → Language bar options → Advanced Key Settings → select Between input languages, Change Key Sequence…, both Not Assigned radio buttons, OK, OK.

protected by Community May 22 at 14:36

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.