2

I have a well-known issue: The "Ctrl + Alt + Down" hot key in Eclipse does not work since my last graphics driver update.

Previously, I could resolve this issue easily by changing/disabeling the "Rotate Screen" hot key in the Intel HD Graphics Control Panel (which controlles the graphics driver). This is also the solution presented in all posts that I know that deal with this issue (see Copy-Lines Shortcut Problem, Monitor Display Turns Sideways or Upside Down, or Ctrl+alt+down arrow key not working in eclipse juno).

However, now I do not find an option to set the respective hot keys in the graphics control panel anymore. Also, the screen does not rotate when I use the short cut. Moreover, I cannot set the screen rotation in the Intel graphics control panel at all. The option disappeared completely.

That is, the key is occupied by some program (presumably the Intel graphics driver), but not used.

So, how can I make the short cut useable again?

I am running Windows 10 64bit and my graphics chip is Intel HD Graphics 530 with driver version 20.19.15.4424.

Update 1: I have tried to install a different version of the driver: 20.19.15.4463. Nothing changed. Has no one an idea?!

Update 2: Following miroxlav's advice (see Try killing your apps until problem is fixed, presumably start with Intel graphics driver) I have killed the igfxHK.exe process with the Task Manager. The problem disappeared. This does already help a lot and tells me that it is indeed the Intel graphics control panel that is causing the issue. What remains to solve is how to fix the problem in the long term, so that I do not have to kill the process every time I restart my computer. Does anyone know which service I have to stop or which autorun I have to disable?

  • Why would a keyboard shortcut be connected to drivers? – Ramhound Jun 18 '16 at 0:27
  • 1
    @Ramhound: When I had this issue previously, it was due to the intel graphics driver, which occupied the respective shortcut. The problem arose when I reinstalled my graphics driver and could not find the option to change the key shortcuts anymore. Therefore, it is likely that the issue is related to this driver. However, I cannot be completely sure, of course. – Samufi Jun 18 '16 at 0:42
  • intel driver – Ramhound Jun 18 '16 at 0:56
  • @Ramhound: I know how to download the recent intel driver. As I have written in my post, I recently downloaded and installed it (this is when the problem occured). Or what do you want to tell me with this link? – Samufi Jun 18 '16 at 3:11
  • 1
    @Ramhound: I have tried the driver you linked and nothing changed. – Samufi Jul 7 '16 at 5:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.