3

Recently, probably after an update, the popup notifications regarding file actions in the standard windows file browser have started opening in the background, behind windows. This is really annoying, as I then have to switch to them via the taskbar in order to confirm actions.

Does anybody know why they stopped opening in the foreground, or what I can do to fix this issue.

I searched online but didn't find any other reports of this, despite the 15 or 20 different ways I wrote the issue in the search box. All I found were standard guides for moving files, or turning on delete confirmations, or guides for other related tasks.

Update: I did find an article regarding this problem, and then found other resources as a result. If you are also having this problem, please see the answer below.

1
2

Well, I found why this occurs @ Fix File Dialog prompts not spawning in the foreground in Windows 10

But I did not find a built-in/permanent solution to the problem.

The linked site says Win8 and Win10 have File Dialog Prompts that, like some other apps, remember stuff about their last window location. So if you click on another window while a notification is open, the next time the notification loads it will do so in the background; but if you leave it in the foreground it will load in the foreground next time too.

This is a stupid thing for Microsoft to do, cause the Prompts often require immediate user action. But they'll just sit there in the background, forever, and wait for the user to notice.

There is currently no known built-in way to 'force' them to popup in the foreground, like they should.

An alternative solution may be to install a secondary app like Dexpot, which allows users to create always-on-top rules for windows that are applied automatically, even after a reboot (so long as Dexpot is set to run at startup).

I created such a rule for "OperationStatusWindow" class windows, and windows with "File Conflict" and "Replace or Skip Files" in the title.

If I dropped the first rule, and left only the rules for specific window titles, than the windows would only be made always-on-top when user action is necessary. But I'd rather play it safe. I can always disable the rule in the rare occurrences where I may not want the windows locked on top.

0

I found a solution here: Attachments or new Windows opening behind current one

  1. open Regedit by using Windows + r -> type regedit
  2. go to HKEY_CURRENT_USER/Control Panel/Desktop
  3. then select the key ForegroundLockTimeout
  4. set it to 0 (maybe save the value somewhere in case-of)
  5. Restart your PC

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.