0

I have a Lenovo Z50-70 running Windows 8.1. The laptop is relatively new, bought in Jan. 2015. (The warranty expired in March 2016.)

Some time ago, the original battery suddenly started to have a problem where it would say 53% available, plugged in, not charging. No matter what fixes I tried (after looking through a ton of articles, posts, comments, etc., and spending a ton of time looking for a solution), nothing made the battery start charging again. It always stayed at 53%.

Then recently it went down to 45% and always only stays at 45% no matter what. Also the battery light/indicator on the front of the laptop is always blinking white.

So I got a replacement battery, put it in hoping that it would work and charge up to 100%, but the replacement is having exactly the same problem as the original battery. It will only charge up to 45%, then it says plugged in not charging, no matter what I do or try. The battery light is again always blinking white.

What can I do? How can this be fixed, or can it be fixed at all? What's going on?

Ideally I would like to be able to have both the original battery and the replacement be able to be charged up to the full 100%, but I'd settle for just being able to charge the replacement up to 100%.

Appreciate any help. Thank you very much.

  • Try this – DrZoo Jun 19 '16 at 2:17
  • Unfortunately that doesn't apply to my laptop, the article says: This feature is being removed via Lenovo Settings Dependency Package 1.3 or later for Windows 8.1, and I have windows 8.1. Also, mine is an IdeaPad, not a ThinkPad. – AnonPerson Jun 19 '16 at 20:28
  • What about Lenovo Energy Management? Is that installed in your laptop? – DrZoo Jun 19 '16 at 21:22
  • Yes it is. I've tried modifying the settings in there but that doesn't fix it. Also, the "battery conservation mode" is always off in the Energy Management Program but the battery still won't charge to any more than 45% no matter what, when it should be always going up to 100%. – AnonPerson Jun 19 '16 at 21:43
  • I see. I've seen when changing battery setting inside of Lenovo Energy Management from "Optimize battery health" to "Maximum battery life" fixes a similar issue. Have you tried uninstalling Energy Management, and then possibly trying a recalibration of the battery? – DrZoo Jun 19 '16 at 21:52
0

You have a few possibilities:

1) Your battery is having issues or needs to be replaced. You've already replaced the battery so we can assume it's not a battery issue.

2) Your power adapter is having issues. Have you tried using a different power adapter with the same specs?

3) The charging circuit on your motherboard is faulty. Unfortunately this usually requires a full mobo replacement in my experience.

Another commenter mentioned the "Microsoft ACPI Compliant Control Method Battery" driver. To rule this out I would boot from a live linux CD/DVD/USB and see how the charging goes. You could also rule this out by simply letting your battery charge with the laptop off. If it still never reaches a full charge then you know its not the driver. I doubt it is the driver as the battery charging light is controlled by low level functions on the motherboard, not from within any OS.

  • Re #2: I don't have any other power adapter, only the one that came with the laptop when it was bought. Maybe it's worth looking into getting another power adapter. – AnonPerson Jun 19 '16 at 19:52
  • Re #3: How would I be able to know or tell for sure that the motherboard charging circuit was faulty? The battery used to charge well to 100% and work well until a few months ago, so if this was a motherboard problem why would it suddenly occur just like that? Also, I don't know anything about Linux, I've never used or had Linux, I only have Windows 8.1 that came preinstalled with the laptop. I already tried deleting and reinstalling that specific driver many times and that didn't fix the problem. I will check charging with laptop off...although somehow I doubt that will work either... – AnonPerson Jun 19 '16 at 20:23
  • There's no way to know for sure if its the charging port unless you check all the onboard components in the circuit. Just because it worked before doesn't mean it hasn't gone faulty since -- the same happens with all electronics in our lives. Components fail. Ruling out all the other possibilities is the best path to a conclusion. Good luck! – kisk Jun 21 '16 at 1:27
-1

I had this battery problem before.

Literally just Google "battery plugged in not charging". Any of the links will help you.

The issue relies with the "Microsoft ACPI Compliant Control Method Battery" which is a poorly written power management driver that comes with Windows. It charges your battery half way to "extend the lifespan of the battery".

  • I've spent many, many hours Googling exactly that, and many variations of it, and I've tried many of the suggested fixes, and none of them have worked for me so far. – AnonPerson Jun 19 '16 at 1:34
  • I've also removed and reinstalled the "Microsoft ACPI Compliant Control Method Battery" driver and reinstalled it several times, as was suggested in many postings, articles, comments, etc, and that didn't fix it for me. What else can be done, if anything? – AnonPerson Jun 19 '16 at 1:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.