3

Not only me but many developers are in the habit of pressing ctrl+s many times to save the file. Here comes the visual studio 15 that open a dialogue to save file as if you press the control+s more then ones.

How to remove the shortcut from the vs 15?

I checked and found that ctrl+s, ctrl+s is assigned to none as shown in screen shot given below: enter image description here

EDIT

I am using a trial version enter image description here

I have following extensions installed enter image description here

enter image description here

The issue was automatically resolved after taking the latest updates of Visual Studio.

I apologise for not updating the question.

10
  • why don't just change yourself? Press save only once
    – phuclv
    Jun 19, 2016 at 7:56
  • why don't you just answer relevant? :P or is it not possible to remove the shortcut? Jun 19, 2016 at 8:16
  • I can't emulate in 15 Preview 2 double Ctrl + S. It does nothing.
    – Misaz
    Jun 19, 2016 at 8:52
  • 1
    You might improve the tags on the post - it is unclear whether you refer to visual studio 2015 or visual studio 15, I use VS2015 professional, and single or double ctrls+s does only save. VS15 is only in Preview (beta). VS2015 has bug reporting under Help / Send feedback, so maybe also VS15. You might consider moving to the stable version of VS2015 rather than VS15. And which is your Preview version?
    – harrymc
    Jul 26, 2016 at 10:17
  • 1
    @VikasBansal: Using a Preview/trial version means there will be bugs.
    – harrymc
    Jul 26, 2016 at 19:31

1 Answer 1

2
+50

Summary :

As this didn't happen on my version of Visual Studio Pro 2015, I suggested running devenv.exe /SafeMode to check for a rogue extension.

This was indeed the case, tracked by @LuizVieira to the extension Visual Studio 2015 Tools for Unity.

This extension has some issues with saving. For example : Why does Ctrl-S not always save?. Here the workaround was :

Going to Visual Studio > Tools > Options> Tools For Unity> General and setting all options from explorer to true

Some other suggestions :

  1. The problem can be a conflict with another extension - see if it arrives when only this extension is enabled.

  2. Try to map Ctrl+S to "Save All" as a workaround.

2
  • In Tools>>Options, I don't find any option Tools For Unity. I have updated and mention the version of Visual studio I am using. As Tools for Unity is not present in my VS then It must not be the reason of the conflict. Also, the issue was resolved when I had taken the updates. Jul 26, 2016 at 17:14
  • 1
    @VikasBansal: Using a Preview/trial version means there will be bugs.
    – harrymc
    Jul 27, 2016 at 5:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .