0

I'm using a Western Digital My Passport Ultra (2TB) 1.5 years ago and I've recently been seeing a lot of problems with this external drive in event viewer.

So far, whenever I connect this to the computer I would receive a large number of errors. This is a list of all the ones I've seen so far (I get multiple instances of them all):

  1. ERROR: The driver detected a controller error on \Device\Harddisk3\DR9 (most common, as in 100 of these per second common)
  2. ERROR: The default transaction resource manager on volume F: encountered a non-retryable error and could not start. The data contains the error code.
  3. ERROR: The file system structure on the disk is corrupt and unusable. Please run the chkdsk utility on the volume \Device\HarddiskVolume3.
  4. WARNING: An error was detected on device \Device\Harddisk3\DR9 during a paging operation.
  5. WARNING: The system failed to flush data to the transaction log. Corruption may occur.

Does this mean that my hard drive is failing? because I've tried running chkdsk (/f /r) and SMART checks and it has passed both with no errors. When I can open the contents of the drive, I can play, copy and paste files in and out of the drive without any issues either.

I am really not sure exactly what is wrong with my HDD (though most of the time I can use it properly, occasionally it says that it is unaccessible). It also makes a very quiet clicking sound rarely, though I noted that it's done that since I first got it so I thought it was normal.

Hope someone can help shed some light on this, and advise me on what I should do to fix this. I'm guessing it is a controller problem but I have no idea what to do to fix it since the only things I can find on the internet are about bad sectors and the usual drive problems. This one seems a little bit different.

Thanks!

  • Possible hard disk failure. Check your hard drives for SMART errors How can I read my hard drive's SMART status in Windows 7?, and What is the easiest method of checking SMART status for your hard drive?. Report back with the results. – DavidPostill Jun 19 '16 at 12:35
  • Hey, thanks for the response but I've already checked the SMART status and it passed (using WD Data Lifeguard and WD Drive Utilities). I will upload screenshots later but there are no problems on that front – BlackVulcan Jun 20 '16 at 7:03
  • This sounds unfortunate, @BlackVulcan! I'd strongly recommend you backup your data from the drive as soon as you can access it before proceeding with the troubleshooting. I'd also suggest you check how the WD My Passport is recognized in another computer. You might also try reinstalling it as a device from Device Manager. I'd also recommend to reinstall the USB Hub Controller drivers for your computer/motherboard from the manufacturer's official website. Hope it helps. Keep us posted & Good luck! – SuperSoph_WD Jun 20 '16 at 13:15
  • Thanks. I've tried it on 2 of my laptops (Windows 8.1 and Windows 10) and they're both showing the same problems. I've already backed up what needs to be backed up and I've tried reinstalling it from device manager. It's really hit or miss though (as in it sometimes works and sometimes doesn't), so I might just claim my warranty on it (as it's only 1.5 years old and it should have a 3 year warranty). Thanks! – BlackVulcan Jun 22 '16 at 4:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.