1

I've upgraded to a new PC (Windows 10) and would like to make a complete backup of all files off my old PC's hard drive (also Windows 10) .

I have plugged the old HD into the new PC, so it is not booting off the old drive.

However, I keep getting "Access Denied" errors, even running 7-zip or xcopy as administrator. For example, G:\ProgramData\ApplicationData gives the error, as do several other locations.

Is there any way I can globally say to not check permissions on this disk, I just want to read all the files?

For safety reasons, I do not want to make any write modifications to the other disk (e.g. taking ownership of files).

1

I ended up using the following solution:

  1. Boot into a live-CD linux distrubution
  2. Mount the disk in question as read-only
  3. Create a tarball on the destination drive , with the source drive as input

This let me access every single file, bypassing permissions, and later I can access the tarball without any permission errors.

I actually used a bash for loop to make separate tarball for each top level directory on the drive, for easier access later.

  • I love this solution. Totally circumvents NTFS permissions and strips NTFS streams (if any). You end up with nice clean files. +1 – misha256 Jun 28 '16 at 3:36
0

When you connect a previously used hard drive to a new or different computer, either as an internal or external drive, you will not have ownership of that drive. When you try to view, add or delete files on that drive, you will get an error message stating: “E:\ is not accessible. Access is denied.” Your drive letter may be different, but you get the idea.

  1. In Windows Explorer, right-click on the drive you want to take ownership of, then select “Properties” from drop-down menu.
  2. Click on the “Security” tab.
    1. Click on the “Advanced” button.
    2. Click on the “Owner” tab in Advanced Security Settings.
    3. Click on the “Edit” Button.
    4. Click on the “Other users or groups” button.
    5. Under “Object Types”, uncheck everything except “Users”, then click on OK.
    6. Click on the “Advanced” button.
    7. Click on the “Find Now” button.
    8. Under “Search Results”, click the “user name” that you log into windows with, then click OK.
    9. Verify the correct user name in the object window, then press OK.
    10. Place a check mark in front of “Replace owner on subcontainters and objects”.
    11. You will see a warning message stating that “All permissions will be replaced…”. This is normal. Click on “Yes”.
    12. A status window will show file permissions being rapidly replaced.
    13. If you see an error message saying “Access is denied”, it’s not a problem. That message only refers to a specific system file that’s currently in use. You don’t need access to it anyway. Just click the “Continue” button.
    14. Click OK on the final Windows Security message.

Almost done.

In Windows Explorer, right-click on the drive you just took ownership of, then select “Properties” from the drop-down menu. Under “Properties”, click the “Security” tab. You should see your user name in the “Group or user names” window. Click on the user name to highlight it, then click on the “Edit” button.

Under the “Allow” column, place a check mark in the box for “Full Control”, then click on the “OK” button.

The hard drive should now show up in Windows Explorer with data about its size and free space. You should be able to click on it, then click on any directory, then add, delete or modify files as needed.

Done!

Source (has pictures -- may be easier to follow; I listed everything here in text format so you could follow if you don't want to use the source).

  • That's not completely true about ownership. The built in Windows accounts like SYSTEM and Administrator and the Administrators group are the same across different Windows installs, even when you're reading from a hard drive pulled from a different system. Issues occur when files are owned by different user accounts, and those files are for some reason missing Administrators = Full Control permissions. – Alex Cannon Aug 7 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.