8

I use VLC for years in Windows and never had that problem. I also use it since my fresh Win10 install last year (by "fresh" I mean it wasn't an update installation but a pure installation after format) so there is less room for problems.

Until yesterday VLC worked fine but since then all videos I ran in VLC doesn't contain image --- Only sound. I should note that I didn't anything special I could mention to the system - I didn't update the Win drivers or anything of the sort.

WMP (Windows Media Player) plays videos fine. There are no malfunctions with the PC itself.

Things I've tried and didn't help:

  1. Reset all VLC prefrences.
  2. Updating VLC.
  3. Uninstalling and reinstalling VLC (updated version).
  4. Unchecking "Accelerated video output (Overlay)" option under Tools->Preferences->Video.

    • I also tried to restart the PC after reinstall - No change.

Update

The video card was most likely to be Asus GTX 570 OC, at the time.

11
+100

I can think of two options to try:

  1. change the output module to OpenGL, you need to select "all" in options to see the advanced options, and this one is at: preferences->video->output module

  2. check/uncheck "Overlay video output". This option is located at preferences->video

| improve this answer | |
  • 1
    I must say that option 1 worked for me by itself, without option 2... Why do you think that is KoKo? And also thanks for you answer !! – user529857 Jun 22 '16 at 21:01
  • By the way KoKo, please correct me if I'm wrong but there isn't any major difference (or no difference at all) between OpenGL or DirectX (or whatever was the former output module) by means of quality image, right ? – user529857 Jun 22 '16 at 21:08
  • It seems indeed from several videos that on OpenGL the quality is a bit poorer than on what was before. – user529857 Jun 23 '16 at 1:33
  • 1
    That could be caused by a number of issues, something wrong with your DirectX installation, or something wrong with your GPU driver, or maybe you need to update your C redistributable library, I'm not sure the cause of the issue, you may have to trial and error. – KoKo Jun 23 '16 at 23:22
  • 1
    I haven't experienced or heard any difference in playback quality between DirectX vs OpenGL, though wouldn't surprise me if difference does exist in certain formats such as the newer x265 codec. – KoKo Jun 24 '16 at 0:22
2

I had a similar problem. Here's my solution:

Whenever I played any video file using VLC (ver.2.2.4 Weather Wax) only the sound would start. Video frame would show outside of the application window but be black or blank. If I then stopped the play (by clicking the STOP button) and then re-started it, the video would show normally.

Additionally, Windows would drop down to 'Basic' from 'Aero' display type.

I observed that this happened only when I ran VLC. If I played that same video file in any other player like mpc-hc (I never use WMP) etc, Windows would continue to remain in Aero scheme and never drop down to Basic.

This indicated to me that VLC was misconfigured somehow - a hunch which proved correct in my case.

After some amount of Internet research, I discovered that if VLC output to Direct X, only then this problem occurred.

But then I noticed that OP had already tried changing VLC's video output module to OpenGL but wasn't happy with that.

So I tried the other Video Output Modules listed in the dropdown menu available in my installation of VLC.

By trial & error, I found that selecting Windows GDI Video output solved the problem, atleast for me. Now, my Windows 7 Professional does NOT drop from Aero Glass down to Basic nor does my video play quality suffer!

VLC Video Output Module Windows GDI selected

| improve this answer | |
1

(Re-)Install some decent video codecs. I believe KLite codec pack is good and is not spamware.

| improve this answer | |
  • Please explain how installing codes will fix videos that played properly before. – DavidPostill Jun 22 '16 at 14:39
  • VLC was completely reinstalled. The other answer below is to reinstall the video drivers. With the information provided this would be my next move. These are pretty standard windows support procedures. – J0hnG4lt Jun 22 '16 at 18:38
  • VLC has all the required codecs, the problem is a performance problem, which means KLite codecs are unlikely a real solution. – Ramhound Jun 22 '16 at 23:49
0

1) -> Go to Tools->Preferences->Video -> Remove the tick for "Accelerated video output (Overlay)" -> Try and play the movie again, you should now see output.

2) Download proprietary drivers for your graphics card - I think theres a thread on the forum dedicated to that. Example, NVIDIA 8600 using the default 11.4 open source drivers (nouveau?) shows a black screen when VLC uses "Accelerated video output". However, installing the proprietary NVIDIA drivers, VLC will successfully show the movie using "Accelerated video output".

To clarify the default VLC installation with "Accelerated video output" ticked - works with proprietary NVIDIA drivers - and doesn't without.

Source: https://forums.opensuse.org/showthread.php/455508-VLC-shows-black-screen-when-playing-movie-files-(solutions)

| improve this answer | |
  • Some note, I already tried to uncheck that "AVO (overlay)" option. If by "output" you mean to video, there still wasn't any video then. – user529857 Jun 20 '16 at 2:26
  • Have you tried to re-download vlc? – Mark Jun 20 '16 at 2:28
  • Yes - That's what I mentioned by reinstalling... It didn't help... – user529857 Jun 20 '16 at 2:56
  • What I meant... – user529857 Jun 20 '16 at 5:34
0

I had the same problem, I found the solution here:

https://kast.zendesk.com/hc/en-us/articles/360031093252-Black-screen-when-streaming-VLC-media-player

In my case changing video to OpenGL this or that, DirectX, and so on resulted only in VLC crashing.

What solved my case was (as in linked post) going to "Input/Codecs" tab, "Codecs" section and changing "Hardware accelerated decoding" entry to "Disable".

| improve this answer | |