1

I am unable to get into the UEFI firmware setting menu at boot time. Symptoms include:

  • None of the F1/F2/.../F10 hotkeys bring out the UEFI config menu. Escape and Del only bring out a useless diagnostic splash
  • Pressing F12 gives the list of bootable entries, one per disk. UEFI config is not among the entries.
  • efibootmgr says: No BootOrder is set; firmware will attempt recovery
  • /sys/firmware/efi/efivars is empty, even after I tried to mount the efivarfs
  • /sys/firmware/efi/vars only contains 2 files: del_var and new_var
  • fwsetup doesn't work on my grub2.02 beta2, but I'm not yet sure if it's because my grub is too old. I enter fwsetup on my grub2 command line and hit enter and nothing shows.

My system is a Lenovo U310 ultrabook with 2 drives. /dev/sda has my debian and /dev/sdb has my Win 10. Windows 10 was installed first followed by debian. I never had any issue with booting these 2 systems before, since they are installed on two different drives, and I always relied on pressing F12 to bring up the list of bootable entries to choose the correct drive to boot into in case I ever wanted to use Windows (default is debian).

Yesterday I replaced the /dev/sda (debian) drive with an SSD with more storage, and installed debian on it again. But this time it wouldn't boot into the new SSD, apparently because the boot entry wasn't written into UEFI (I can still make it boot into the new system by copying the bootloader to a fallback location for removable media). That's when I tried looking into UEFI config and realized I can't access it.

I tried using Windows 10 to boot into UEFI config following this guide, but UEFI Firmware Settings doesn't exist in Advanced options. This probably indicates something is totally wrong with my UEFI. I tried efibootmgr and dug into /sys/firmware/efi/xxxvars and realized there's nothing there.

One interesting thing is that, even though neither Windows 10 nor my linux systems can see the UEFI settings, my machine still shows a debian entry when I press F12 at boot, even after I've removed all my drives. So clearly UEFI boot entries aren't dead.

Any idea how I might get back into UEFI config menu? Right now I just want to set the default boot device to my new SSD so that I don't have to treat it as a removable media everytime...

  • 1
    It sounds like a combination of a buggy EFI and/or damaged NVRAM entries. I recommend you contact the manufacturer, although I don't really hold out much hope that they'd be able to help, except perhaps by returning it for repair/replacement. Since the system boots OK (albeit using the fallback filename), it may be simpler to just live with it as-is than to try to get it fixed. – Rod Smith Jun 23 '16 at 13:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.