2

There are several questions asked the same way; I have been trying various solutions for 3 days with no luck; that's why I am asking from scratch.

I have a wireless router and a wireless access point attached with a cable. Router is DHCP Server (192.168.1.1), access point has DHCP disabled with a fixed IP (192.168.1.250).

I have 8 machines (Windows 8.1 and Windows 10) connected to the router both wirelessly and wired. The problem is; all of the machines can ping each other except one. (192.168.1.154). This Windows 10 box cannot ping the server (192.168.1.147). Of course the server cannot ping it back either.

Shortly; 154 can ping all the network except 147. 147 can ping all the network except 154. So much weird enough; when I connect 154 to the access point rather than the router, it can then ping 147. Weird more; I can cross-see them in each other's arp table as dynamic entries.

I installed Microsoft Network Monitor, cleared arp, reset netsh both for TCP and Winsocks, and started cleanly capturing the network traffic. I can see this machine (154) sends an arp request to the server (147) by IP. In a matter of seconds, IP resolves to the server's name correctly. Then arp -a command lists the server by it's IP and MAC dynamically. But still cannot ping! (Most of the times connect timout. Less, "host unreachable")

Sometimes the server gets off the arp table arbitrarily and gets back in.

What I have tried so far:

  • Turn off firewall on both machines. (No 3rd party firewalls installed.)
  • Turn off firewall on the router (no MAC or IP filters)
  • Turn off isolation on the router
  • Change IP of both machines, both to automatic and something else fixed.
  • Try adding a static arp entry on both machines.
  • Run network related services which are set to run manually.
  • Turn on network discovery and sharing on both machines.
  • Set network type to "private".

Yesterday, two different machines were in this situation and there was no problem with 154. It was able to connect to the server. Today, that two machines can connect to the server but 154 cannot. Yesterday those 2 machines were also able to connect using the access point.

I bet this is a crappy Windows issue. Any ideas?

  • Just an idea: IP conflict. Maybe some machine goes in hibernation (or whatever it is) and meanwhile another one takes the same address... when the first waked up it is possible it found an IP conflict. Try to disconnect from the net the problematic machine and connect again. BTW If the machines are (almost) always the same ones, why not to fix their IPs? Ps> Welcome on SuperUser. – Hastur Jun 20 '16 at 12:00
  • A few suggestions - first, try booting "154" with a linux live CD to help isolate whether or not it is an OS configuration issue. Second, use the program wireshark to take a look at the packets being sent by "154", both locally and from a different machine on the LAN. Use the utility arp-ping (elifulkerson.com/projects/arp-ping.php) to evaluate the difference between how ARP packets (which seem to work) and ICMP (which don't) are formed. Lastly use the tool nmap to do a full scan of your LAN to see if you have dup IPs; dup MACs (VMs?) or any other surprises – Argonauts Jun 20 '16 at 12:41
  • @Hastur, most of them are already fixed IPs but actually it's nothing to do with it. Because I tried forgetting the network and connecting back with a fixed and dynamic IP, it didn't work. Connecting brand new machines has no problem! – Turab Jun 20 '16 at 12:58
  • 1
    It's packet capture time. Get a Wireshark capture running on both .154 and .147 and see where the ICMP pings are being dropped. – Mark Riddell Jun 20 '16 at 19:36
  • I agree with @MarkoPolo here - a pcap on both ends will tell you definitively where your ICMP traffic is and is not going. – MaQleod Jun 20 '16 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.