0

I’ve tried using several iPhone apps to connect to my Mac (a 2012 Retina MacBook Pro running OS X El Capitan) via SSH, but it never seems to work.

I have remote login turned on and know my Mac’s IP address, and I’ve even been successful in connecting to it over SSH from other computers, so I don’t think it's a permissions problem or anything like that. I’m telling the iPhone apps to connect to the admin account (and I’m giving the correct password), and I’m using port 22, which all of the apps seem to suggest.

Are there any other reasons why SSH possibly couldn’t be working. It’s telling me that it can't connect to the given server, not that it can't find the server?

  • You say you know your Mac’s IP address but are you trying to do this on a LAN or via a WAN? SSH is SSH; it’s nothing magical at all. So this is most likely a networking hiccup of some kind. – JakeGould Jun 20 '16 at 21:46
  • @JakeGould I've got both the phone and the computer connected to the same wifi network, so I suppose I'm doing it over that. – Nick Jun 20 '16 at 21:50
  • Are you using a 192.168.xx.xx IP or something else? No need to give the full address, just your last comment doesn't quite answer Jake's question – Simon Sheehan Jun 20 '16 at 21:51
  • @SimonSheehan I tried using both the numerical ip address and the name-of-mac.local one. The first one it wasn't able to connect to and the second one it wasn't able to recognize by name. – Nick Jun 20 '16 at 21:54
  • Was the IP local? Like 192.168.xx.xx? – Simon Sheehan Jun 20 '16 at 21:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.