I installed active perl on my win2k12 server, I want to run a perl script but it showing this message, 'C:/Perl64/bin/' is not recognized as an internal or external command, operable program or batch file. I change environment variable path like C:\Perl\bin,C:\Perl\site\bin,C:\Perl64\bin. but what ever path i changed same path is not recognised as an internal or external command.

  • How do you run the perl script? By double click or from the command line? Where are your perl binaries actually installed? – Hermann Schachner Jun 21 '16 at 6:21
  • i am running perl by command line. and my perl binaries are on this path C:\Perl64\bin. – Bharat Karale Jun 21 '16 at 7:10

A) the script to be run

a) Slashes

Have a look at the script you want to run. Most probably, the first line will look like


or similar. Change the forward slashes to backslashes and try again.

b) Executable

Of course, the shebang above misses the executable binary. So if it is missing from your script, change it to



#!C:\Perl\bin\perl.exe -w

if you want to have Perl output warnings.

B) your Perl installation

Have a look at C:\Perl\bin\ and C:\Perl64\bin\ respectively. Do both exist? If not, change the shebang in your script to

#!C:\Perl64\bin\perl.exe -w

C) Alternative

I was assuming that you simply run or double click script.pl. If you want to tell Windows to run that script with a certain application (Perl, in your case), run your script via

C:\Perl64\bin\perl.exe -w C:\path\to\your\script.pl
| improve this answer | |
  • thank you !!! I tried this all but its not working. this path I have C:\Perl64\bin\ . In environment variable C:\Perl64\bin;C:\Perl64\site\bin; this both path are there. I tried by changing there sequence. but its showing that "C:\Perl64\bin" is not recognized as an internal or external command. path is whatever I set first path into environment variable. – Bharat Karale Jun 21 '16 at 7:25
  • That's interesting. Could you add at least the first couple lines, shebang and included modules of your Perl script to your question? Also, however I am sure that it does not matter, try to add a backslash to the end of the elements in your path: C:\Perl64\bin\ . Does your script run with C:\Perl64\bin\perl.exe -w C:\path\to\your\script.pl? – stueja Jun 21 '16 at 11:10
  • Does it work as expected meanwhile? Or could you post the beginning of your Perl script here? – stueja Jun 23 '16 at 5:18
  • thank you so much you stueja for helping me a lot.my issue is solved. – Bharat Karale Jun 25 '16 at 7:55
  • Good to hear that. Feel free to accept the answer if I could help you or let me know what else we could try. – stueja Jun 25 '16 at 8:06

Actually it was an environment variable issue. I was using Oracle 11g r2. and its path didn't have oracle name in it. I am searching "oracle" word from perl script into environment variable, but I was getting the first path which was perl path, so perl was failing to run. The issue is solved. Thank you so much, stueja.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.