0

New installation of CentOS 7.2 with Apache 2.4.6. Trying to install the remi repo so that I can upgrade to PHP 5.6 (yum only provides 5.4). When trying to install the repo from an rpm, I get the following error:

rpm -Uvh remi-release-7*.rpm
error: Failed dependencies:
yum is needed by remi-release-7.1-3.el7.remi.noarch

Obviously, I have yum, so I don't know what the problem is. I've never seen this before when trying to install a repo. EPEL came over fine.

  • 1
    yum clean all Then try removing that '*' asterisk in the rpm -Uvh remi-release-7*.rpm There is also the yum localinstall remi-release-7.rpm option. – rjt Jun 21 '16 at 22:00
  • About yum localinstall : Today this will do : # cd Downloads/ && yum install [package(s).rpm] – Knud Larsen Jun 22 '16 at 11:22
0

You can install the RPM with yum: sudo yum localinstall remi-release-7*.rpm

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.