3

I want to run Firefox (and Thunderbird) automatically on logon. I thought I had a solution - which is running "Startup Applications" and adding an entry for Firefox to execute: /usr/lib/firefox/firefox. Now, that works in a sense, when I log out and log back in, it runs Firefox. However Firefox asks if I want to make Firefox the default browser (which it does not usually do). So I say OK, which is fine, but then if I happen to close Firefox and launch it manually from the Unity Launcher, it asks again if I want to make Firefox the default browser.

So it seems that running /usr/lib/firefox/firefox at startup is different to running it from the launcher (different profile?). I want to make them equivalent. Is there some argument I can add to the Startup Applications list to make the automatically started-up Firefox the same as the manually started-up one?

A similar issue seems to happen with Thunderbird - it doesn't seem to be using the same profile as my usual one (see below) - for example, it failed to log into my mail server.

Thunderbird question

I am using Ubuntu 14.04.


Update

I've used the Firefox debugging page to find the location of my profile directory. It definitely is the same with both invocations of Firefox (and my bookmarks are the same). However I still get asked the question (below) when I change from the auto-started Firefox to manually invoking it. I suppose I can uncheck the box "Always perform this check ..." but it seems oddly disturbing that there is some difference in the execution that it asks the question in the first place.

Firefox not default browser


Further clarification

Each time I see the above message these days, I click on "Use Firefox as my default browser" and uncheck "Always perform this check when starting Firefox" (not in that order, obviously).

However every time I go from the invocation from login, and the invocation from manually starting it, I get the dialog box again. Which is weird, because wherever they are storing my answer, it isn't remembered.

migrated from unix.stackexchange.com Jun 22 '16 at 7:07

This question came from our site for users of Linux, FreeBSD and other Un*x-like operating systems.

2

Try in terminal:

$ firefox --new-instance -ProfileManager

You will get something like this:

ffoxuserprofile

Then to run with a specific profile:

$ firefox --new-instance -P "Default User"

Here you can also find profile directories.

(Note: I have to use --new-instance, because I already have the browser open to answer this).

If it works, I guess you could use /usr/bin/firefox -P "Your Profile" in your startup command, to have the Firefox load that profile at startup.

Also, you may want to try marking the "Use the selected profile without asking at startup" checkbox...

Hope this helps...

  • It's a nice suggestion, however I had updated my question to say that both ways of starting Firefox ended up with the same profile directory. So the test must be done before loading the profile. Maybe the working directory influences that? – Nick Gammon May 20 '16 at 22:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.