4

My Laptop has two GPUs, an on-board HD3000 and an NVIDIA card. On Windows 7 they behaved all right. On the desktop the on-board HD3000 was usually used, but as soon as I launched a game the NVIDIA card took up the job. I know this because there is a little LED which changes its color depending on the graphic card currently used.

Now after updating to Windows 10 the GPU switch is going crazy. Sometimes they are switched several times within a minute, but most often the NVIDIA card is used, even when I am just browsing plain websites (e.g. currently while writing this). When I have the plain desktop on the screen and do nothing, the HD3000 is used after some seconds, but as soon as I move the mouse it switches again. This gets really annoying when watching youtube videos or streams via chrome. There can be minutes when the HD3000 is used constantly. But every now and then (sometimes several times in a minute) it changes to the NVIDIA card and back again after some seconds. The video stops for a second when it switches to the HD3000. Sound remains consistent.

Summing up I didn't recognize any real and understandable pattern behind this. I would expect Windows 10 to start using the NVIDIA card when the HD3000 approaches its performance limits, but I would have guessed that moving the mouse should not require that much power, not even on Windows 10.

Is there any way to get it working as before on Windows 7? If not, can I somehow disable or forbid Windows 10 to use the NVIDIA card for desktop applications? What would you do?

Here some more information about my system:

  • Laptop Asus N53SV-SX711V
  • Windows 10 Pro x64, Version 1511 Build 10586.420
  • CPU: Intel Core i5-2410M @ 2.30GHz, integrated GPU: HD 3000
  • GPU: GeForce GT 540M, Driver 368.39
  • RAM: 8GB

Edit

I found out here, that the HD3000 is officially not supported by Intel. But "not supported" obviously doesn't mean it cannot be used, since in fact it's used sometimes. Also I can open the Intel Control Panel and change settings (driver version 9.17.10.4229).

Still: What can I do/try? What would you do except disabling the HD3000 completely?

  • What is the make and model laptop? – SiXandSeven8ths Jun 23 '16 at 16:26
  • 1
    Which graphics card is used is selected by NVIDIA Optimus. That’s what you need to configure. – Daniel B Jun 23 '16 at 19:57
  • 1
    Also, I think your on-board video card (HD3000) is not supported on Windows 10. Try to disable it by booting into the BIOS, find the menu item that closely matches "Integrated Peripherals" or "On-Board Devices." The setting to disable the on-board graphics card may also be under the "Advanced" option. – harrymc Jun 25 '16 at 19:14
  • 1
    They were supposed to enhance the use of the GPU, but either they were for a very different version of Intel, or this is because of the general problem on your computer. Sorry, but without physical access to your computer, all I can suggest is to continue playing with the settings of Intel and Nvidia in the hope of arriving at a good balance. – harrymc Jun 27 '16 at 9:41
  • 1
    And in your case, I think it is the Windows Usage of Visual Computing that makes NVIDIA Optimus to prefer the dedicated GPU. In other word, Windows is too heavy to be handles by integrated graphic all the time. – Soroush Falahati Jun 27 '16 at 18:53
1

Since the Windows 10 Spring Update 1803, Windows now directly exposes this type of functionality for all graphics cards, regardless of make or model, as long as they implement WDDM 2.4. This means it will work for Intel, AMD or Nvidia graphics all the same!

If you look for a settings panel called "Graphics Settings", you can add applications and pick which GPU they should use. It's a little involved because you need to manually add any software and games you want to run on the dedicated graphics card, but I find it an acceptable trade of.

To find these graphics settings, search for them in the start menu, or right click your desktop, and click "Display settings". Scroll down the window, and you'll find a link to open the graphics settings panel:

Graphics settings under Display

From there, you can easily add and configure what software should run on which card:

Graphics settings panel

Sadly, I haven't found a way to change the default card for all applications.

It seems to incur a significantly higher bandwidth cost than traditional Optimus, though I haven't been able to measure this since I can no longer get traditional Optimus to run on my laptop.

2
  • Your laptop's internal monitor is connected to your Intel GPU

  • Your HDMI port is connected to your Nvidia GPU

  • Intel GPU can send commands to Nvidia GPU so the system can still draw on the internal display without connecting the internal monitor directly to the nvidia gpu
  • Your Nvidia GPU will be active when anything is connected to the HDMI port and the Nvidia driver is not disabled
  • Your PC uses your integrated Intel GPU all the time. Both GPUs are active at the same time.
  • If you want your Nvidia GPU to be inactive you can set your preferences using Nvidia control panel but you also need to disconnect your HDMI monitor.

enter image description here

  • If your definition of a GPU "being awake" is, that it is directing the output to the monitor, you are probably right. If it is that it is currently doing the graphical calculations, then you are wrong. It happens that the indicator light indicates that the Intel GPU is used even though another monitor is connected via HDMI. And this is what I care about - about the power consumption. And the physical "design" has not been changed, but it worked before on Windows 7. – Rob Jul 1 '16 at 11:55
  • can you try disabling nvidia driver from the device manager and connecting a monitor to your hdmi? I have a similar generation laptop myself. I will try the same now and report the results to you soon. – Uğur Gümüşhan Jul 1 '16 at 12:00
  • I tried it. i connected my hdmi and saw my desktop wallpaper on my tv. then i disabled nvidia on device manager. it disabled the hdmi monitor and gave me a blank screen. – Uğur Gümüşhan Jul 1 '16 at 12:04
  • My main concern is the power consumption in battery mode. And when my PC is on battery, it is most often not connected via HDMI to something. Setting the NVidia optimus settings doesn't help in this situation either as discussed with harrymc. And how do you know my integrated Intel GPU is active all the time? – Rob Jul 2 '16 at 10:35
  • because I read the manuals. run gpu-z and see for yourself if you want. – Uğur Gümüşhan Jul 3 '16 at 1:34
1

Summary of the above discussion :

The Asus N53SV-SX711V laptop has the NVIDIA Optimus architecture, supposedly being able to automatically switch between two graphics adapters to provide either maximum performance or minimum power draw to optimize battery life. To this end, this laptop has both the on-board Intel HD3000 and the NVIDIA GeForce GT 540M GPUs.

Of the two cards, the HD3000 has no Windows 10 driver, and Windows 10 is not listed as supported.

On the other hand, Windows 10 itself, having prettier screens than those of previous versions of Windows, might also require more graphical muscle than is available via the HD3000. This might explain why Windows switches to the NVIDIA GPU continuously and in an irregular manner, despite having juggled many performance settings in the NVIDIA and Intel control panels.

You might accept that behavior of Windows, or if the battery is sufficient even when running with the NVIDIA card, permanently disable the HD3000 in the BIOS. This might be possible by booting into the BIOS, finding the menu item that closely matches "Integrated Peripherals" or "On-Board Devices", or possibly under the "Advanced" option.

  • @Rob: I wonder if in the NVIDIA Control Panel, Manage 3D settings, you can force individual programs such as the browser to use the HD3000. – harrymc Jul 2 '16 at 11:58
0

There is a thread on NVIDIA forums regarding the problem you are experiencing. You can check it out here https://forums.geforce.com/default/topic/860554/geforce-mobile-gpus/windows-10-and-optimus/ .

Was your card supported on windows 8? If so you could try using windows 8 drivers. The issue you describe is not 100℅ related to the lack of support.

Currently you have 3 solution's: - Use Nvidia's hot fix driver; - Use windows 8 driver; - Downgrade to a previous Windows version

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.