13

Chrome does prompt and offer to save passwords. However every time I click Save, it doesn't actually save. The Manage passwords - Saved passwords is an empty list.

In chrome://settings/search#password both

  • [√] Enable Autofill to fill out web forms
  • [√] Offer to save your web passwords

are checked. Tried uninstall and install, tried sign-out and sign-in again.

5 Answers 5

15

I got this problem but wasn't using Google to sync passwords, so the accepted answer wouldn't work for me.

As of the time of writing (Chrome 60), I managed to get passwords saving again (based on a hunch) by doing the following:

  • Close Chrome
  • Delete the following (in my case, <ProfileName> was Default):
    • ~/Library/Application Support/Google/Chrome/<ProfileName>/Login Data
    • ~/Library/Application Support/Google/Chrome/<ProfileName>/Login Data-journal
  • Relaunch Chrome, try saving a password, check the saved passwords list in advanced settings

If you can't see the Library folder in Finder, go to your home directory, View > Show View Options > Show Library Folder.


In my case I migrated my Google Chrome configuration from one Mac to another. While most things survived intact, the passwords did not -- and like the OP I would get the save prompt but nothing would get saved.

My profile was deliberately NOT synced with Google, and so I wanted to avoid deleting the entire profile if I could help it.

The hunch was that I was looking for something that would store credentials (and so would feature a word like "credential" or "login") and would be a database (and so would probably have a "journal" file alongside it).

I haven't noticed any side-effects, so it seems to have paid off. That said, I would recommend backing things up before deleting random files. :)

4
  • I had the exact same issue after migration the profile-folder from one computer to the other. Removing Loding Data* fixed it for me too. Finally!
    – jottr
    Jun 29, 2018 at 14:36
  • I do my best to minimize information sharing with google. So deleting my complete profile is not an option as I would lose all bookmarks, history, customisation... Thanks a million for this simple and effective solution !
    – CuriousFab
    Jul 10, 2018 at 0:24
  • 1
    Thanks a bunch! Had the same issue with a browser based on Chromium. In that case the folder which hosts Login Data and the journal is ~/Library/Application Support/Chromium/Default. Mar 5, 2019 at 13:58
  • 1
    Still relevant (and working!) for Chrome 72
    – Andenthal
    Mar 13, 2019 at 17:23
10

With an hour of search and trial it got fixed. Initially I thought it was an OSX issue. Because I recently had an El Capitan upgrade and it gave me a hard time with KeyChain. I have other devices, iOS and OSX, none of which has any problem of password syncing.

I tried Disconnect and re-connect, not working.

enter image description here

Shouldn't have stopped there. It turned out to be a problem of user profile after all. The right place to edit is actually here.

enter image description here

Clicking the X deletes the current user and apps. No worries, signing-in again reinstall them back in a blink. All my saved passwords in account got synced as well. Happy autofilling ever after.

1
  • On Chrome 80: Remove your user from Chrome: Click profile picture -> Cogwheel -> 3 dots on the profile -> Remove. WARNING. This will close all open tabs. So make sure to export them to disk via Session Buddy extension or the like.
    – avalanche1
    Apr 13, 2020 at 11:57
-1

The desktop is synced with icloud in latest osx update. If your browser icon isn't on the desktop it is going to adversely effect the browser. Open finder and drag the browser icon to the desktop and leave it there. Browser should be fine now.

-1

Uninstall chrome and remove the chrome folder from ~/Library/Application Support/Google/Chrome/ and install again.

1
  • The issue is already resolved and the method for resolution is well described. There is no need to provide additional answers to the question with an accepted answer. Mar 21, 2017 at 3:48
-1

As soon as I saw "Keychain" in the above comment it was clear ...went to keychain ...typed the root word for the site with the incorrect and unsaved updated passwords ...opened the keychain for that site -erased incorrect password and replaced it with correct one ...clicked "save changes" -tried logging in to site ...new password was there.

All within Mac OS and no need to get into anything potentially messy such as terminal or re-installing Google Chrome xoxo :)

1
  • 1
    The issue is already resolved and the method for resolution is well described. There is no need to provide additional answers to the question with an accepted answer. Jun 13, 2017 at 3:30

Not the answer you're looking for? Browse other questions tagged or ask your own question.