2

Problem

I can't get numlock enabled by default on login screen of my Windows 10 machine. I read many articles/questions with solutions like these:

And after trying them all, the only working option was disabling Fast Startup from Control Panel.

However as name suggests it is good option and I don't want to have slow startup, just because numlock will be enabled.

Notice

As I already wrote, all solutions with changing registry key InitialKeyboardIndicators to 2 or to 2147483650 or to 80000002 failed to work.

Also I did it for all possible folders in HKEY_USERS folder, not just for HKEY_USERS\.DEFAULT

Question

I am wondering if there are any other options to enable numlock by default on login screen as it is bit annoying?

  • Did you try setting the value of InitialKeyboardIndicators to 80000002? – Michael D Jun 27 '16 at 10:32
  • @MichaelD just did it, does not work as 2 and 2147483650. – gevorg Jun 27 '16 at 10:39
  • Did you change inside every required folder? Please take a look at Step One of this page. Edit: Also change the values for ALL USERS not only for .Default. – Michael D Jun 27 '16 at 10:41
  • @MichaelD yes, I did, just tried it with all possible combinations. – gevorg Jun 27 '16 at 11:04
2

Okay try the following for Win10:

  • Change the value of ...ControlPanel/Keyboard/InitialKeyboardIndicators to 2147483650 for ALL USERS not only for .Default.

  • Then SHUTDOWN computer.

  • Turn on computer and wait for login screen (NumLock is still off).

  • Enable NUMLOCK

  • SHUTDOWN computer.

  • Turn on computer.

  • Thank you for answer and certainly what you explain works as you write, but when I continue after described steps in answer 1. Login to to windows 2. Shutdown 3. Turn on => numlock is disabled again. :( – gevorg Jun 27 '16 at 11:07
  • Oh, I am too out of ideas. Sorry. – Michael D Jun 27 '16 at 11:12
  • It sounds like maybe group policy or domain policy could be rewriting the registry value. – GaTechThomas Sep 12 '16 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.