I'm able to SSH to into other machines using MobaXterm, but when I try to run the Local terminal, the Tab just opens and closes all by its own. Am I missing something like a config file ? I tried running it as an Admin as well, but no luck.

I am on Windows 7 Enterprise Edition 64bit and started with MobaXterm v9.0. I tried totally uninstalling MobaXterm v9.0 (including deleting the CygUtils plugin) and then installing the latest MobaXterm v9.1 and CygUtils plugin. However, the same problem persists.


9 Answers 9


Update: I just now helped someone with this and the solution that worked was uninstalling the "installation" version and then downloading and using the "portable" version.

For my installation, there are files in C:\Users\username\Documents\MobaXterm.

Perhaps back them up (especially if you have SSH keys or other important files or configuration in them) and then delete that directory before another clean install of MobaXterm.

If you've tried all of the solutions on this page that make sense, you can also try contacting Mobatek to file a bug report.


I had the same issue in the portable version. I fixed the problem in 3 steps :

  1. I downloaded the CygUtils.plugin (http://mobaxterm.mobatek.net/CygUtils.plugin),
  2. Put the file above in the directory where MobaXterm exe file is
  3. I removed MobaXterm .log, .ini and backup files in the same directory
  • 1
    REALLY ?!? you honestly instruct us to remove .ini and LOSE ALL SAVED SESSIONS ?!? thank you very much, FOR NOTHING !!!! Jul 17, 2020 at 13:22

You must enable Enable Windows Subsystem for Linux feature on Windows 10 and then it works. Here is a link how you can enable this: How to Enable Windows Subsystem for Linux

  • please note that I specifically mentioned that this error occurs on a Windows 7 machine, NOT A WINDOWS 10 machine. Feb 26, 2018 at 22:47
  • Please note, that this actually fixed my problem. Thanks Stefan.
    – Jamie Carl
    Feb 27, 2018 at 0:01
  • 1
    TURN THE POWER ON DUDE ... not only that I have the same problem, and WSL is on, but cygwin HAS NOTHING TO DO with WSL, and MobaXTerm is based on cygwin, otherwise it will NOT work on older windows Jul 17, 2020 at 13:24
  • Note that I have the same issue as the OP but I am under WSL (v1) and Windows 10. It lacks documentation on how to configure the automatically created WSL session. It returns immediately when I connect to WSL.
    – рüффп
    Jul 28, 2020 at 7:46

Same problem form me, solved by backup and then delete the config file: C:\Users\Your_Name\Documents\MobaXterm\MobaXterm.ini

if you have changed you document home directory, then find the file MobaXterm.ini in MobaXterm of that directory.

You can use the tools everything to find it easily.


Like others I openen C:\Users\username\Documents\MobaXterm, but deletion of the MobaXterm.ini did not help. I also had to delete the .log file before MobaXterm woke up again.

Tip: do not delete the .ini file but rename it to MobaXterm.bak.ini. This way you still can copy some of the old configuration data out of it to use in the new one. I saved my bookmarks this way.


You must download CygUtils.plugin and put it in same directory MobaXterm exe file is. This apply to install & portable version.

This plugin is required to run local terminal. You can find this information on 'Home screen' on the bottom. There is also direct link to download it.

You can get it from here: http://mobaxterm.mobatek.net/CygUtils.plugin


In addition to having CygUtils.plugin in the same directory as MobaXterm.exe (or MobaXterm_Personal_10.5.exe in my case), you may need to set your MobaXterm home directory (and possibly root directory) to Windows folders to which you have modify access. You can do this in MobaXterm by going to Settings->Configuration->General and setting the "Persistent home directory" and "Persistent root (/) directory" to the folders of your choice. Worked for me. I was inspired to try this by stumbling on Where does MobaXterm keep its home directory?


I encountered the same issue. The problem was due to a dll conflict between cygwin and mobaxterm (which is delivered with an integrated cygwin). I removed the path of original cygwin from the %PATH% environment variable, rebooted the PC, and everything works fine now.



My solution was to remove everything from the installed directory, except the .ini file and licence file. Then put the portable version in the same directory.

Not the answer you're looking for? Browse other questions tagged or ask your own question.