8

I have been trying to migrate a laptop from a HDD to an SSD. I initially cloned the drive with the latest version of TODO Backup and then tried with Macrium Reflect. Both have the same problem. The drive clones fine and all the files appear to be present, but Windows 10 won't boot.

I have booted from a recovery disk, loaded a command prompt and run:

bootrec /RebuildBcd
bootrec /fixMbr
bootrec /fixboot 
bootsect /nt60 SYS

It still doesn't boot. If I load the Windows 10 recovery disk and boot from the CD I can then select to load Windows it will load. Likewise, if I select reboot rather than shutdown, the machine loads.

This is how the SSD drive looks in drive manager: SSD partition

When trying to start the system after shutdown, it permanently sits on a black screen with a flash _.

The partitioning on the source disk is MBR. I am cloning to an Integral P Series 2.5 inch Solid State Drive (120 GB, 4 SSD, SATA III Drive).

  • I ran into similar issues attempting to clone my Win 10 SSD (40GB) to my new one (256GB) using Acronis. I spent a good week on it before I gave up and reinstalled it on the new drive completely. – Thebluefish Jun 24 '16 at 22:48
  • I don't normally recommend software, but the program I am going to suggest has never failed me, paragon-software.com/technologies/components/migrate-OS-to-SSD up to you if it's worth a try or not though – Ramhound Jun 24 '16 at 23:07
  • 2
    one lazy way , is to install the system normal, which gets all the mbr/gpt stuff set, then drop the partition clone in overwriting the partition, which has all your additions and customisations. That trick worked with most of the windows systems. – Psycogeek Jun 25 '16 at 4:54
  • What is your source disk partitioning MBR or GPT howtogeek.com/193669/… ? How old is your cloning software? What is your SSD type? – Vojtěch Dohnal Jun 27 '16 at 8:44
  • And what is the type/brand of computer you are trying to run it on? Some laptops have BIOS limitations. – Vojtěch Dohnal Jun 27 '16 at 9:31

10 Answers 10

13

The solution that worked at first try for me:

Windows 10 Fix Error After Cloning HDD SSD - Error in file winload.efi

  • With Windows 10 installation/recovery media open the command prompt in advanced tools

  • Diskpart

  • list volume (take note of boot partition volume and windows partition letter)

  • select volume X (X partition responsible for booting the system, hidden partition in fat32)

  • assign letter w (to be able to recover the boot files)

  • exit (exit diskpart)

  • bcdboot X:\Windows /s w: /f UEFI (X partition letter that contains the Windows folder)

  • reeboot system (select the new boot option if more than one)

  • msconfig (Boot - delete the \Windows options and leave only the c:\Windows option)

Hope this helps many of you!

  • This have worked for me! It may be accepted as the answer – Slifer Dragon Jun 4 '19 at 22:44
  • This worked for me after upgrading a Dell Vostro 3470 from 1GB SATA IDE to 1GB NVMe SSD (installed in PCI slot using a RIITOP NVMe Adapter M.2 PCIe SSD Converter Card) using Acronis True Image 2019. I did not have to run msconfig though. Otherwise, I was getting an INACCESSIBLE_BOOT_DEVICE BSOD for the first few reboots after cloning, and then it would enter Dell recovery mode. – humbads Jul 11 '19 at 2:12
2

Since you have a way of booting into Windows on the SSD, you can do a Repair install of Windows 10 by performing an in-place upgrade without losing anything.

You should first verify the partition alignment as described here.

0

I think there is some problem with boot files or boot order.

The first thing you can do is disable fast startup by going to power options.

As fast startup uses a kind of hibernation techniques.

If it doesn't work perform an in-place upgrade without loosing your data. This will create new boot files and settings.

  • I have tried an in place upgrade, but I still see the same problem. – psych Jun 29 '16 at 15:44
0

I struggle with similar problem with Windows 8.1.

When cloning from HDD to SSD, partitions serial and GUID kept intact. But I not want to remove original HDD from system. So I needed to change GUID (in GPT for FAT EFI partition) and remove windows system partition from original HDD after cloning and before boot recovery.

When partition ID is non unique windows work strange, for example PE recovery unable to detect both HDD and SSD.

  • I don't believe this will help me. I am removing the old HDD from the system so it shouldn't be a problem. – psych Jun 29 '16 at 15:26
  • @Mikhail Moskalev I suspect this is the case in my scenario want to keep both drives in my PC but use the newer larger one for my main OS drive... How did you go about changing the unique identifier on the drive? I am unable to boot Windows at the moment but could boot from a flash drive. – Liam Mitchell May 31 '19 at 2:41
  • 1
    @LiamMitchell As far as I can remember, I changed GUID by gdisk tool from linux boot usb. – Mikhail Moskalev Jun 12 '19 at 11:19
0

I had this same problem, just create windows installation usb drive from official site, boot up from installation usb, then go to troubleshooting, start CMD there and copy all files (and folders) that start with boot* and efi* from installation usb to root directory of cloned SSD drive, after doing that my cloned SSD was able to boot. Also check your boot settings in bios.

0

I ran into this same issue cloning my OS drive to a new SSD and was able to resolve it.
I noticed I had two Windows Boot Manager listed that pointed to the original drive.
1: I downloaded BootIce v1.3.4 by Pualy.
2: I went to the UEFI tab>> Edit boot entries button
3: There were two Windows Boot Manger listed in the listbox on the left, they both pointed to the same hard drive.
4: I selected one of them and changed it to point to my new SSD>> Click Save current boot entry button. 5: When I rebooted and went into the BIOS i was able to change the boot priority to the Windows Boot Manager of the new drive.
Success! I am now typing this from the Windows 10 loaded from the new SSD.
I plan on formatting the old one for secondary storage once I feel comfortable this is stable.

0

just met the same problem, actually a small mistake on 2nd clone of 2nd new laptop.

1st laptop clone, connect alone and boot up ok, the default hard disk connect on 2nd boot and formatted without problem.

But on 2nd laptop clone, connect newly clone SSD and original hard disk still with win10 in it, although choose boot with SSD, then wipe the hard disk OS, next time failed.

Solution: use Macrium Reflect bootable disc, go to restore > fix Windows Boot problem, it auto fix the boot manager. Remind next time after clone, boot the cloned disk alone without original source disk, connect after 1st boot.

0

Reload windows to the new drive like you are doing a fresh install, then use AOMEI Backupper free to clone only the windows partition to over top of the windows partition on the new drive and overwrite it with the windows partition from the old drive.

  • I tried this. Install onto an SSD using a bootable Windows 10 32-bit (1903) USB installer. Reboot w/target drive to make sure it works. Power down. Clone previously configured Win10 installation from old HDD to SSD in external USB docks using AOMEI Clone (Partition). Boot target SSD. Error: "reboot and select proper boot device." Boot MiniTool Partition Wizard from USB; set first SSD partition active. Boot SSD again. Recovery: error 0xc000000e. Boot Win10 installation USB. Repair > command > bootrec /rebuildbcd. Success! – Ray Woodcock Sep 1 '19 at 3:19
0

This answer may already be posted, however I did not see it.

Too simple: Go into computer management: then to storage disk management, and identify the new cloned drive.

My software does not return the cloned drive with a name, therefore add a name , usually C: and then the drive should be recognized, and boot properly. Hope this works for you, it did for me.

bfhjr

0

Fixed, here is what you do ...

You f2 force boot with the SSD. You use the command prompt in admin to navigate disks with the following

  • LIST DISK
  • SELECT DISK n -- n is the disk you want (HDD storage)
  • LIST PARTITION
  • SELECT PARTITION n -- the system one

inactive

If this won't allow because the HDD is not MBR, you need to clear your HDD (make sure to backup) and reformat the HDD to MBR. This makes it so the UEFI can't open the HDD to boot as MBR HDD only boots to legacy BIOS. Launching with the Windows Boot Management straight into the only drive available to launch. The SSD

To convert HDD to MBR you need to do this. You use the command prompt in admin to navigate disks with the following

  • diskpart
  • list disk
  • select disk n (disk you want to convert)
  • clean
  • convert to mbr

Once it's MBR, you repeat the 1st couple of steps to make the drive partition inactive.

When restarting the drive will not be able to be used as there are no partitions (you have cleaned the HDD). Access the Disk Management menu and add new volume by right clicking the drive. You can assign the letter and enjoy your new storage drive that is MBR. Booting with the NVME SSD

Not the answer you're looking for? Browse other questions tagged or ask your own question.