I do Arabic translation at my work and I create fillable forms using Word. Today I noticed the text field for Arabic input looks like a small square instead of a rectangular shaded area. Please see the image below.

enter image description here

Note that the English input fields on the left have been added for comparison; they are not an artifact of the problem.

Normal in 2010 (properly formatted input boxes for Arabic):

enter image description here

It's only happening when trying to type in Arabic. Data input works properly. The problem is that the Arabic version of the input boxes displays a small square input placeholder, and the shaded input field doesn't appear until text is typed. The problem behavior is shown this video.

It looks like the new update for Office 365 did something weird. It was normal before and there is no problem when trying it in Office 2010.

I tried to remove and re install without any luck.

  • 2
    What is the actual issue? It sounds like you're complaining about a change in appearance of an entry box, but you haven't described a problem with entering values. – fixer1234 Jun 25 '16 at 3:24
  • It is as you mentioned only the appearance problem. I dont have problem entering values. My only concern with the ugly appearance when you print your final work because it will be filled with small squares instead of normal file. I attached second pic which show the normal case when you insert a text filed from from the developer legacy option in (Office 2010). Do you have solution for that? – user610125 Jun 25 '16 at 17:18
  • In the 1st image, does the input appear in the input boxes on the left, or is that static and the input is displayed in the squares on the right? If the latter, how do the squares display the text? (the squares expand to contain the text? The text expands outside the squares? The squares are a tiny window onto a few characters of the input?) Can you choose which boxes to use for input? When you say it only happens when trying to type in Arabic, is that the default language setting for the document or are you switching between English and Arabic within the document (and how do you do that)? – fixer1234 Jun 25 '16 at 17:34
  • Please see thi video explaining the problem: youtube.com/watch?v=gZyL-BSKx-8&feature=youtu.be – user610125 Jun 25 '16 at 20:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.