0

Whenever I perform a search in Windows, I get broken icons for some apps. They mostly seem to be Windows store apps (calculator, calendar, mail, camera).

Anyone knows how to fix this?

enter image description here

  • maybe clearing the icon cache can solve it? – magicandre1981 Jun 26 '16 at 6:34
  • I tried this: www.howtogeek.com/232779/how-to-rebuild-a-broken-icon-cache-in-windows-10/. But there are two files that I cannot delete, I get an "access is denied" message. – Maria Ines Parnisari Jun 27 '16 at 2:39
  • which files can't you delete? – magicandre1981 Jun 27 '16 at 15:06
  • iconcache_idx.db is one and the other I'll tell you when I get home :) – Maria Ines Parnisari Jun 27 '16 at 15:07
  • have you opened the cmd and closed Explorer as told in the guide? – magicandre1981 Jun 27 '16 at 15:33
0

This was driving me crazy, but this fix solved it for me. I really don't recall checking that box, though. Anyway, I unchecked it and APPLIED TO ALL FOLDERS, rebooted. First try it didn't work and them it started working (probably caching).

Solved Broken Icons source

Problem solved I had to uncheck "Always show icons, never thumbnails" in folder option --> View Tab and restart computer.

0

In my case it was settings being synced between machines via my Microsoft account.

I tried all sorts of fixes, including repairing Windows Store Apps, SFC, clearing icon and thumbnail cache files, etc. I tried switching the System > Advanced System Settings > Performance > Settings > Show thumbnails instead of icons. I tried Explorer > File > Change folder and search options > View > Always show icons, never thumbnails. I tried disabling the syncing of Other Windows settings under Settings > Accounts > Sync your settings.

The only way I was able to fix the issue was:

  1. Turn of settings syncing with your Microsoft account on all Windows installs. (Settings > Accounts > Sync your settings)
  2. Go to https://onedrive.live.com/win8personalsettingsprivacy and click the Remove button to delete the cloud copy of all settings
  3. Convert your Window account to a local user account, thereby unlinking it from your Microsoft account (Settings > Accounts click the Sign in with a local account instead link)
  4. Create a new Windows account on the machine, first as a local-only account so you can pick your username (Settings > Accounts > Family & other people then Add someone else to this PC).
  5. Log into the new account and go to Settings > Accounts to link it up to your Microsoft account
  6. Move settings and files from your old local account to the new account
  7. Remove your old local account
  • 1
    Please do not post the same answer to multiple questions. If the same information really answers both questions, then one question (usually the newer one) should be closed as a duplicate of the other. You can indicate this by voting to close it as a duplicate or, if you don't have enough reputation for that, raise a flag to indicate that it's a duplicate. Otherwise tailor your answer to this question and don't just paste the same answer in multiple places. – DavidPostill Feb 5 '18 at 21:57
  • Creating a new account is more like a workaround then a proper fix :( – Ricardo Amaral Mar 23 '18 at 12:39
  • @RicardoAmaral Unfortunately I found no way to resolve the issue other than to create a new account and move the data over after purging the stuff from OneDrive. I spent quite a while online searching and trying various methods. This was the only one that allowed me to keep my Microsoft account-based login and fix the issue. All of the others that worked just involved creating new local login accounts no tied to a Microsoft account. – wbond Mar 24 '18 at 15:01

Not the answer you're looking for? Browse other questions tagged or ask your own question.