0

I'm attempting to run an FTP server on a raspberry pi, and after a lot of struggle I finally made it work, however for some reason the server doesn't place users into a chroot jail, and everyone can access all files on the device. Strange is that I did set chroot_local_user to YES, but it doesn't work as I said. Any ideas?

# Example config fil /etc/vsftpd.conf
#
listen=YES
listen_ipv6=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
local_umask=022
dirmessage_enable=YES
use_localtime=YES
xferlog_enable=YES
connect_from_port_20=YES
chroot_local_user=YES
user_sub_token=$USER
local_root=/home/$USER/ftp
  • I have the directory set up, the owner is root and write perimissions are disabled for all users, and it was done before I started vsftpd (tried reboot as well with no effect) – DELTA12 Jun 26 '16 at 16:44
  • See if this helps you any just in case: serverfault.com/questions/544850/… – Pimp Juice IT Jun 26 '16 at 18:45
  • Okay something REALLY weird is going on. I can connect to the ftp server even if the service vsftpd is disabled! I have a fresh install of raspbian and I didn't use any other ftp servers. – DELTA12 Jun 27 '16 at 13:23
0

It appears that I was connecting to a different ftp server all along (probably the stock sftp server?). I made vsftpd run on a different port and now it works fine (does chroot users)

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.