2

I am trying to shrink a NTFS partition on which, currently, Win10 is installed. The hard disk is a SSD. Disk management utility is not allowing me to shrink even a bit. It shows the amount of shrink available is 0 MB.

I understand from the output that due to immovable objects of Windows at the end of my partition, I cannot shrink further. I went through the following question and tried everything to get rid of immovable objects in my partition.

How to shrink Windows 7 boot partition with unmovable files

I disabled pagefile, hibernation, and system restore. I even deleted temporary files and ran disk fragmentation multiple times but this utility doesn't allow me to shrink.

I have an installation of Ubuntu 14.04 on my second hard disk (HDD). I gave up on Disk Management tool and thought of giving GParted software a try. I ran it inside that Ubuntu. Unfortunately, it is also not allowing me to shrink. GParted gives the following warning:

Unable to read the contents of this file system!
Because of this some operations may be unavailable.
The cause might be a missing software package.
The following list of software packages is required for ntfs file
system support:  ntfsprogs / ntfs-3g.

It seems that GParted is missing some package so I installed the ntfs-3g (which contains ntfsprogs), but this also did not help remove the error. I tried

ntfsfix /dev/sda4

It could not identify any issues. So, I referenced to following thread http://ubuntuforums.org/showthread.php?t=1244058, and ran the command

sudo ntfsresize --info --force --no-progress-bar /dev/sda4

It showed the following output:

ntfsresize v2013.1.13AR.1 (libntfs-3g)
Device name        : /dev/sda4
NTFS volume version: 3.1
Cluster size       : 4096 bytes
Current volume size: 248417088000 bytes (248418 MB)
Current device size: 248417091584 bytes (248418 MB)
Checking filesystem consistency ...
Accounting clusters ...
Cluster accounting failed at 8553265 (0x828331): extra cluster in $Bitmap
Cluster accounting failed at 8553266 (0x828332): extra cluster in $Bitmap
Cluster accounting failed at 8553267 (0x828333): extra cluster in $Bitmap
Cluster accounting failed at 8553268 (0x828334): extra cluster in $Bitmap
Cluster accounting failed at 8553269 (0x828335): extra cluster in $Bitmap
Cluster accounting failed at 8553270 (0x828336): extra cluster in $Bitmap
Cluster accounting failed at 8553271 (0x828337): extra cluster in $Bitmap
Cluster accounting failed at 8553272 (0x828338): extra cluster in $Bitmap
Cluster accounting failed at 8553273 (0x828339): extra cluster in $Bitmap
Cluster accounting failed at 8553274 (0x82833a): extra cluster in $Bitmap
Filesystem check failed! Totally 2878 cluster accounting mismatches.
ERROR: NTFS is inconsistent. Run chkdsk /f on Windows then reboot it TWICE!
The usage of the /f parameter is very IMPORTANT! No modification was
and will be made to NTFS by this software until it gets repaired.

So, I went to Windows back and ran

chkdsk /f /r

and rebooted twice hoping that problem would have been resolved. chkdsk does not find any problem. I also checked for any errors using the "check" option under "Error checking" section of Properties of my partition. Nothing helped. ntfsresize still considers my NTFS partition as inconsistent. I don't know what to do next. I just want to shrink my NTFS partition and install another OS on it. Also, I want to avoid deleting the partition altogether. Any sort of help will be appreciated.

2

I was having the identical problem. The problem seems to be that it's necessary to specify which disk to check:

chkdsk C: /f /r

This fixed the problem. Or possibly it was the fact that I had also tried other arguments such as

chkdsk C: /scan
chkdsk C: /spotfix

which successfully ran without rebooting. Use

help chkdsk

to see other options.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.