2

Quick backstory: I'm attempting to resolve "unknown errors" that come up trying to upgrade from Windows 7 to Windows 10. Whether or not this issue has anything to do with it doesn't matter, I just want it fixed regardless.

So, in trying to fix some Windows 7 errors, I discovered that msconfig.exe's boot tab is frozen and attempting to modify anything results in this error message:

The system cannot find the path specified

Not only that, but going into Advanced System Settings > Startup and Recovery provides me with this dropdown that suggests

I have no OS?

And if that wasn't weird enough, going to bcdedit revealed that apparently my boot configuration store (correct term?) is missing from the default location and is instead in c:\ESD\Windows\Boot\BCD for some reason.

enter image description here

Things to note:

  • I am on Windows 7 Home (genuine)
  • I only boot Windows 7 (always have)
  • I have 4 disk drives (all SATA) and one other that USED to be my primary drive before I cloned it to my current primary drive (I suspect this to be where my problems started ;) )
  • I currently cannot do a repair install as I have traced back this error from an error with attempting to do a repair install

So: How do I fix this? Can I modify something to look in the other path? Can I move the incorrect path somewhere else so it can be found? Am I missing the root of the issue entirely?

I would appreciate if someone could get back to me before July 29th in case it fixes my Windows 10 upgrade errors too!

Update 7-17-16: I have tried several other suggestions (thanks, magicandre1981) but unfortunately none have fixed the issue:

  • Booting from a Windows 7 iso and attempting an auto-repair (yields "the partition table does not have a valid system partition" and claims to fix it successfully, yet nothing changes despite running it multiple times)
  • Booting from a Windows 7 iso and using "bootrec /fixmbr", "bootrec /fixboot", and "bootrec /rebuildbdc" (/fixmbr and /fixboot say "completed successfully" and /rebuildbcd identifies 1 OS, but when attempting to add it, it says "Element not found")
  • Booting from a Windows 7 iso and executing "bootsect /nt60 all /mbr" (runs successfully, but nothing changes as far as I can tell)
13
  • boot from Win7 DVD and go to autorepair and let Windows fix BCD Jun 28, 2016 at 4:32
  • Unfortunately that gives me this error: link I was hoping that one would be solved by fixing this. And yes, I am using the Windows 7 SP1 disc that I got when I bought my PC.
    – That Guy
    Jun 29, 2016 at 0:56
  • this is wired. I never seen this message before. try a different Win7 ISO. Use this trick to get the ISO via MS page: superuser.com/a/1091004/174557 Jun 29, 2016 at 4:11
  • Interesting, I'll try it and report back.
    – That Guy
    Jun 30, 2016 at 0:30
  • Good news: that let me make it into the command prompt. Bad news: upon trying to /rebuildbcd, I get this error (though it does detect my windows installation) link. Weird news: bcdedit can only find the store when my primary drive is the only one plugged in (this is what shows up link).
    – That Guy
    Jul 2, 2016 at 3:59

1 Answer 1

1

Tl;dr: I had my drives plugged into the wrong SATA ports. I needed the SSD with Windows to show up as drive 0 (by physically plugging it into port #0).

Everything seems to work now.

Time to try that Windows 10 upgrade...

Why this works: Not 100% sure, but it appears that Windows 7 only checks the first drive it discovers in certain situations (such as msconfig's boot tab, running bcdedit in CMD, etc.) despite the fact that it can boot from an out-of-order drive just fine.

1
  • this is really strange. Nice to hear that you fixed it Jul 21, 2016 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.