1

I have a Tablet PC that runs Windows x86 and Ubuntu x64 (mixed mode) on UEFI 32 bits with GRUB2 installed. I've tried to boot a Windows x64 WinPE image using wimboot program on GRUB2 because it appears to support Intel IA. The problem is that, when it boots, a color screen appears and I've to force shutdown. Can I do anything to make it boot or it's incompatible with my hardware?

To make it boot I mount a loop device with the iso. My configuration on grub2:

    menuentry "Windows 10 64 bits" {
     insmod fat
     insmod iso9660
     set root=(hd0,gpt3)
     loopback loop /winpe.iso
     linux16 /wimboot
     initrd16 \
     newc:bcd:(loop)/Boot/BCD \
     newc:boot.sdi:(loop)/Boot/boot.sdi \
     newc:boot.wim:(loop)/sources/boot.wim
     }

And GRUB shows no errors when loading it.

1
  • There is this answer to more general question. The fragments "What would the loaded operating system do? It will most likely look for a CDROM, which it won’t find, and fail" and "If you're trying to boot a non-Linux LiveCD, you may be out of luck" may be relevant in your case. Jul 7, 2016 at 10:14

2 Answers 2

0

wimboot from the iPXE project is by default built as a combined x64 EFI and "kernel compatible" boot image, this is just like a Linux kernel with EFI_STUB enabled. As such the answer about wimboot being a 16 bit binary is not correct, anything that is running in EFI mode, should call wimboot as it is an efi binary. Either Grub is missing this feature, or it's implementation of correctly detecting EFI binaries are buggy. Also note that when running in EFI mode, the support files (bcd, boot.sdi, boot.wim etc) should not be cpio packed, but rather should just be loaded into efifs memory.

-1

GRUB2 UEFI didn't support linux16 and initrd16 command

GRUB2 UEFI use linuxefi and initrdefi instead

wimboot is 16 bit binary and GRUB2 can't load it in UEFI Mode

if you edit your config like this linuxefi /wimboot

the result Will be like this error no efi header

so that is Impossible to load Winpe ISO in GRUB2 UEFI until now

the only way to boot Winpe in GRUB2 UEFI Mode that Extract the contents of the Winpe iso to fat32 partition and that partition can't include any Windows OS.

1- add tag to Winpe Fat32 partition named it any thing like Winpepartition.tag

2- configuration on grub2: menuentry "Windows 10 64 bits"{ insmod part_gpt insmod chain search --file --no-floppy --set=root /Winpepartition.tag chainloader /efi/boot/bootx64.efi }

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.