0

I have a relatively new (<1yr.) Dell Inspiron 15 laptop, which stays plugged in all the time. It's connected to a flatscreen monitor via HDMI & I keep the lid shut, so that screen's off.

Yesterday I noticed after I shut it down that the 'charging' LED was lit after shutdown, so I turned it back on to see why. The battery was at 98% charge & said it would be 5 minutes before fully charged.

While I was using it throughout the day, it was doing a 'full' antivirus scan, & I was watching Netflix. Nothing draining really.

I don't understand how the battery could have been draining while it was plugged in. Can anybody offer an explanation?

Thanks

  • Have you run any diagnostics on your battery? Have you tried a different power supply? – imtheman Jun 27 '16 at 21:11
2

Latest hardwares has this feature where it shuts the power supply to the battery when it is full and recharges it once it reaches a lower point. This is to avoid overcharging (not exactly, due to heating problem and other sort). Can't quite get the name of the feature though. This was a problem during earlier days, that is why people still say don't keep the laptop or mobile always plugged, that it might destroy the battery. But this has long since been solved using this feature. Will post if I find some articles on it.

  • Maybe you mean Dell's "Advanced Charge"? – jehad Jun 27 '16 at 21:14
  • Well, might be, every brand has their own name for it I guess, but let's just call it "Battery cut-off". It's on most of the tech now-a-days anyway. – Michael D Jun 27 '16 at 21:17
  • True, especially business and high-end laptops have this cut-off feature these days. My comment was based on "Christopher Bartels" question where he states that he has a Dell. – jehad Jun 27 '16 at 21:23
  • Oh, good to know, I was unaware of that name because I've not used Dell before. – Michael D Jun 27 '16 at 21:27
  • So I looked & saw there's an app called 'Dell Power Manager Lite' [1], & it has a feature called 'Advanced Charge' [2]. But it's never been enabled- default is off [3]. Now I've enabled & configured it [4], so I expect it to work this way from here on. But it doesn't explain why I encountered this behaviour in the first place while it had yet to be enabled. I'll just have to wait & see how it goes now after having enabled it. [1]: i.imgur.com/xQZnldW.jpg ; [2]: i.imgur.com/bO59bcM.jpg ; [3]: i.imgur.com/5BA9rVf.jpg ; [4]: i.imgur.com/gRdWr38.jpg – Christopher Bartels Jun 27 '16 at 22:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.