9

After an upgrade, most of the programs reasonably stopped running or refuse to run with the message "/lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.17' not found", ls, apt-get, insmod, networking modules.....
so now I lost networking , it does not recognize usb sticks.
Am I right to assume that the only solution is to boot from USB and then overwrite the current version with a more recent one ?

EDIT : I use Ubuntu 14.04, the problem happened after apt-get upgrade, I don't know precisely from what version to what version the glibc was upgraded, probably from something to 2.17
I don't need a step by step guide, just directions.
EDIT :

All programs depending on libc do not work anymore.

EDIT :

USB sticks are not recognized, the usb modules don't work, they must depend on libc, no change in syslog from the system when a USB stick is inserted.

6
  • Please edit your above post to include OS information. ( Upgraded [OS name] from [version] ... to [new version] ) . Commented Jun 28, 2016 at 15:25
  • A simple upgrade cannot have caused this mess. I run the same OS, Kubuntu 14.04, and have experienced nothing like this. Also, the current version of glibc provided by libc6 is 2.19-1. Agreed you do not have glibc_2.17-1, but do you have any version of libc.so.6 at all? What is the output of apt-cache show libc6? Laslty: if USB sticks are not recognized, you may use a live version of Ubuntu to boot, then install libc6 from that onto your hard disk via a chroot. Commented Jun 28, 2016 at 16:53
  • I found out I have the 2.15 version, apt-cache does not work. that's what I was asking, is overwriting a solution or am I gonna run into more problems? Commented Jun 28, 2016 at 17:09
  • Which alternative do you think you have, right now? Commented Jun 28, 2016 at 17:28
  • After overwriting, when I try to chroot It fails and I get "inconsistency detected by ld.so" Commented Jun 28, 2016 at 18:23

3 Answers 3

3

Where I messed up:

I was trying to install some library that depended on glibc 2.15, and so I installed glibc 2.15 with dpkg and thus overwriting my system's version which it was 2.19. The vast majority of linux programs depend on glibc and since they were built with 2.19, they got angry with me and stopped working, commands like ls, apt-get, aptitude, ping, ifconfig and insmod...

How I fixed it:

  1. I boot from a USB stick, downloaded all the packages related to glic 2.19, there is a red point for the packages on which depend glibc.
  2. mounted the partition:

    mount /dev/sdax /mnt

  3. extracted the contents of these packages in root:

    dpkg -x foo_bar.deb /mnt

  4. updated the ld cache:

    ldconfig -r /mnt

  5. reboot

3
  • So basically, you did what I told you to manually via USB... Which you said wasn't working.
    – acejavelin
    Commented Jun 29, 2016 at 13:06
  • @acejavelin thank you for taking the time to think about solving my problem. Commented Jun 29, 2016 at 15:47
  • 2
    Wow! This actually worked. If you're really brazen, you can do this live int eh OS you're running. I was one step away from blowing away my system and decided to give it a try. YOLO! After that I was able to continue with apt install -f and recover the rest of the way.
    – Paul
    Commented May 19, 2017 at 22:58
0

You don't have a high enough version of glibc, so you need to update it...

In a terminal window, enter:

sudo apt-get update
sudo apt-get install libc6

Should take care of it.

5
  • thanks for replying, but apt-get does not run and networking programs like ifconfig, ping..... Commented Jun 28, 2016 at 16:07
  • @BaroudiSafwene Perhaps you can download it from here: packages.ubuntu.com/trusty/libc6 and transfer it over with a flash drive and install it manually?
    – acejavelin
    Commented Jun 28, 2016 at 16:19
  • Unfortunately USB sticks are not detected. Commented Jun 28, 2016 at 16:30
  • @BaroudiSafwene You can try a "dirty" install, but my experience with that is hit and miss... If possible, I would backup what you can and do a fresh, clean installation.
    – acejavelin
    Commented Jun 28, 2016 at 16:32
  • this doesn't help
    – stiv
    Commented Aug 15, 2019 at 10:53
-1
  1. copy (ls cp tar touch) from the bin of the server which is running on 12.04 to the bin of server 14.04 having the issue by mounting a cd or a drive
  2. use

    /path for 12.04 cp file/cp ls /bin/ls
    /path for 12.04 cp file/cp tar /bin/tar
    /path for 12.04 cp file/cp touch /bin/touch
    
  3. dpkg -i libc6_2.19-0ubuntu6_amd64.deb
  4. restart

my issue solved

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .