0

I have a new Dell XPS15 which came with Windows 10 preinstalled. I completely wiped it and installed Slackware Linux. I can only run Linux in UEFI Secure Boot OFF Mode or Legacy Mode. When I start my laptop in Legacy Mode, the SSD drive gets mounted, but the bios says it cannot recognize my battery charger and refuses to charge the battery. When I run in UEFI Secure Boot OFF, charger is recognized but my SSD(Samsung) does not get mounted - i.e. it does not show as an option in devices to boot from and if I boot SlackWare from USB drive fdisk does not show the SSD drive. My bios version is 01.00.07. Can anyone suggest a fix? If possible, I would like to avoid updating the bios as it is very risky.

1

I found the answer - you need to switch RAID to AHCI for the SATA operation. This way you can boot in UEFI Secure Boot OFF and get the SSD mounted. Check this http://ubuntuforums.org/showthread.php?t=2301071&page=2

  • Ah, yes, the RAID option for disks always looks like it would be a good choice with no downsides. Then you find the downsides. – Andrew Morton Jun 28 '16 at 18:35
  • Actually any ideas why the bios would not recognize my battery charger and refuse to charge the battery. I need to run in Legacy Mode because UEFI Secure Boot OFF gives me a Hard Drive issue (I don't use the hard drive) and does not wanna start the bootloader. – niko Jun 28 '16 at 20:19

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.