7

Why did anyone ever it would be a good idea to disable Num Lock on Linux at startup? It annoys the heck outta me.

7

Most laptops need numlock disabled to be able to type normally - it would be a very bad idea indeed to indiscriminately enable numlock. Nik's link tells you how to change this, but you asked why and that's why.

  • I have a laptop and I don't have this problem. I've used Windows for as long as I can remember with the NumLock enabled by default. – Pieter Feb 16 '10 at 9:52
  • 1
    Not all laptops are the same - but a lot have (had?) a 'numpad' in the middle of the keyboard, that's active if numlock is on, so you cannot type normally with it on. – Bobby Feb 16 '10 at 12:36
  • It's really a bad idea to allow OS to control this setting. It has to be controlled from the bios, and there must be additional option, like in troubleshooting section "Force disable numlock on startup (For buggy laptops)". Other way - dont TOUCH it, please, or you wreck it. I really gave up, finding how to tweak it. And now I just want to set a pistol to head of person, who wrote that malicious code and force him to uncode this part back!! (joking, but it was really awful idea) – xakepp35 Oct 29 '19 at 8:19
6

You seem quite frustrated on this,
Maybe this Ubuntu page for NumLock will help.

  • 2
    +1 for the advice, but I asked why it is disabled by default so I'll have to mark Bobby's answer as correct. – Pieter Feb 16 '10 at 9:53
  • 1
    The page is totally outdated as per today, ubuntu does not contain System Settings > Keyboard Layout > Options > Miscellaneous compatibility options page anymore.. – xakepp35 Oct 29 '19 at 8:15
0

At least in Ubuntu 16.04 LTS, this behavior might be because of a bug:

https://askubuntu.com/questions/509029/numlock-light-turns-off-when-you-switch-language-with-super-space

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.