0

I'm using a really strange print server, from win-star, model WS-NU78W44, trying to share a HP LaserJet M1120 MPF. When I tried to use the print server's installer, on windows, it worked well, but now when I send it to print it CRASHES before printing: from Google Chrome, from explorer, from Paint, everywhere I try to print.

So, I started reading about LPD/LPR or something like that as an alternative, and it didn't work as well after trying to add a local printer, selecting LPR port, adding an ip and not setting a queue name. Nothing prints. So I decided to use a mac machine.

To my surprise, adding this printer as lpd, not setting a queue name and installing it's proper printer drivers, it works. Why when trying to set this printer, as LPD/LPR on my windows, as local, without a queue name, and sending it to print, it doesn't work, but when I do it using the mac it does? What's the catch? Does OS X send a "default" queue name? How do I debug this?

PS: This printer model isn't listed as a compatible one in the manuals, but since it printed from the mac I believe it will be possible from windows.

1

The M1120 is a GDI (host-based) printer, which depends on the PC's (or Mac's) graphics engine to convert the page into dots on the paper. These printers are notoriously hard to network. To successfully network them from a PC you either

  1. Share them from a PC or
  2. Use a printserver that is specifically compatible with your printer.

The website you linked shows 2 printer support lists for the WS-NU78W44. Neither of them mentions your printer, so you must assume it will NOT work.

I do not know why the Mac does work, but my rule for GDI printers is: if it is not in the printserver's support list, do not buy that printserver.

The queue name relates back to the old Unix BSD days, when printers used parallel ports, and were shared between workstations. The LPD daemon used the queue name name to select the printer. These days LPD lives in the printer and, while initially printers were fussy about correct queue names, modern printer will accept just about anything. Some printers use specific names for certain settings, but if it's not understood, the printer just assumes a generic queue.

  • The thing that bogus me is why it worked on mac but not on windows: but since you're saying it depends on graphics engine this may be the problem instead of queue name or whatever I was thinking was the real culprit. I think I would be better in installing Ubuntu Server in an old machine and setting a samba share. – Somebody still uses you MS-DOS Jun 29 '16 at 13:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.