Jedit is a great text editor, and I love that it is truly cross-platform. I usually use it on windows and just recently spent a long while working on some stuff on my linux box and noticed a large difference in performance. Switching between buffers, in particular, takes much longer than on windows.

I'm using Ubuntu 8.10 and latest version of Java from Sun, tried using -xms/x from 128M to 2048M and it only seems to impact the time it takes to load the program. I tried upgrading to the lastest jedit in the repos (4.3pre17) but that has not helped either. I disabled all plugins (I use projectview, buffertabs, and a few others) but this did not change anything.

I don't know if this is a jedit-specific problem or a java issue in general; jedit is the only program I run in that way (invoking java on a .jar, etc) Does anyone else run it and could recommend some tweaks to either to improve performance?

3 Answers 3


I'm using ... latest version of Java from Sun

Did you install from the Sun website, or from the Ubuntu repository (sun-java6-jre)?

If you installed from the repo, you might still be using the default Java version instead, which can be rather slow.

Run: sudo update-alternatives --config java

This will show you which versions are installed and which version is used by default.

If the Sun version is not selected, select it by doing:

sudo update-java-alternatives --set java-6-sun


got the same problem with OpenJDK Runtime Environment (IcedTea6 1.6) (fedora-29.b16.fc11-i386) Okay it's Fedora :-) but changing the JDK to SUN Java(TM) SE Runtime Environment (build 1.6.0_16-b01) everything runs fine.

Using SUN's jdk will speed up things




Try going to "Utilities > Global Options > jEdit > Text Area" and disabling everything connected with anti aliasing. Usually that speeds it up a bit.

  • 2
    Of course those DirectDraw options only apply to running jEdit under Windows
    – basszero
    Commented Aug 6, 2009 at 12:16
  • Ugh, screwed up. That's what happens when you're in a hurry... Removed. Commented Aug 7, 2009 at 6:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .